p PatchFirst

CVE-2026-73260

CVE-2026-73260 · Mongoose: Out-of-bounds Read via length-counter underflow in built-in TLS X.509 DER parser

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Mongoose is an embedded web server and network library. Prior to 7.23, the built-in TLS certificate parser selected by MG_TLS_BUILTIN fails to verify that a long-form DER element length fits within the remaining certificate buffer. In mg_der_to_tlv() and mg_der_next(), a peer-controlled length can advance the parser beyond the certificate and underflow the remaining uint32_t length, causing mg_tls_parse_cert_der() to continue walking an invalid pointer. An unauthenticated malicious TLS server, or a client presenting a certificate to a server configured for client certificates, can trigger an out-of-bounds read and denial of service during the handshake. This issue is fixed in version 7.23.

CVSS 7.5 · Alta · EPSS 0,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • mongoose

    Versiones
    • < 7.23: Afectada

    Sin corrección publicada

  • mongoose Debian:14

    Versiones
    • 7.21+ds-1
    • 7.21+ds-1~bpo13+1
    • 7.21+ds-2
    • 7.22+ds-1
    • 7.22+ds-1~bpo13+1
    • 7.23+ds-1~bpo13+1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.23+ds-1

    Actualiza a 7.23+ds-1

  • mongoose Ubuntu:26.10

    Versiones
    • 7.21+ds-1
    • 7.21+ds-2
    • 7.22+ds-1
    • 7.23+ds-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →