CVE-2026-73974
CVE-2026-73974 · linuxfabrik-lib: Arbitrary root file read via live --test argument (lib.lftest) across sudoers-whitelisted plugins (LPE)
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
linuxfabrik-lib provides Python modules for database access, caching, shell execution, and API integrations, and Linuxfabrik Monitoring Plugins uses its shared testing helper across check plugins. Prior to linuxfabrik-lib 6.1.0 and Linuxfabrik Monitoring Plugins 7.0.0, lib.lftest.test() treated the first or second element of a --test CSV argument as a filesystem path and returned the file contents as simulated standard output or standard error without path confinement. The hidden but production-accessible --test argument was accepted by sudo-authorized plugins, so an attacker controlling the nagios or icinga account could use check-plugins/deb-updates/deb-updates with its default QUERY=1 to disclose every line of a root-readable file. Approximately 22 other plugins exposed filtered content or a root file existence and readability oracle through the same helper, while check-plugins/network-bonding/network-bonding and check-plugins/openstack-swift-stat/openstack-swift-stat had direct read paths that bypassed the helper. The library fix confines fixture reads to the invoking plugin's unit-test directory and refuses unsafe anchors, and the plugin fix routes the two bypasses through that helper. These issues are fixed in linuxfabrik-lib 6.1.0 and Linuxfabrik Monitoring Plugins 7.0.0.
CVSS 5.5 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
monitoring-plugins
- Versiones
- < 7.0.0: Afectada
Sin corrección publicada
lib
- Versiones
- < 6.0.1: Afectada
Sin corrección publicada
linuxfabrik-lib PyPI
- Versiones
- 2.0.0.0
- 2.0.0.7
- 2.1.0.0
- 2.1.0.4
- 2.1.1.15
- 2.1.1.5
- 2.1.1.7
- 2.2.0
- 2.2.1
- 2.3.0
- 2.4.0
- 3.0.0
- 3.1.0
- 3.1.1
- 3.2.0
- 3.3.0
- 3.4.0
- 3.4.1
- 4.0.0
- 4.0.1
- 4.0.2
- 4.1.0
- 4.2.0
- 4.3.0
- 4.4.0
- 5.0.0
- 5.1.0
- 6.0.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.1.0
Actualiza a 6.1.0
Fuentes originales
- https://github.com/Linuxfabrik/monitoring-plugins/security/advisories/GHSA-rh9c-rqvg-f7pr
- https://github.com/Linuxfabrik/lib/commit/d665042c55fae83a295ebc0023e8b77f6c473a28
- https://github.com/Linuxfabrik/monitoring-plugins/commit/f6680a9e4b39569f318feefdb2f51e5d18c7dad5
- https://github.com/Linuxfabrik/lib/releases/tag/v6.1.0
- https://github.com/Linuxfabrik/monitoring-plugins/releases/tag/v7.0.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-73974