p PatchFirst

CVE-2026-83557

CVE-2026-83557 · jackson-databind omits java.lang.Comparable from DefaultBaseTypeLimitingValidator's unsafe base types

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

DefaultBaseTypeLimitingValidator is the PolymorphicTypeValidator applied automatically whenever @JsonTypeInfo is used without an explicitly configured custom validator. It denies polymorphic resolution only for a fixed set of "unsafe base types", and its isSafeSubType method returns true unconditionally for every base type outside that set. java.lang.Comparable was absent from the list despite being implemented by a very large fraction of JDK and application classes, comparable in breadth to java.io.Serializable, which is on the list for that reason. An application declaring an @JsonTypeInfo-annotated property or class with Comparable as its base type, and no custom PolymorphicTypeValidator, will accept a type identifier for essentially any class implementing Comparable. This yields an attacker-controlled object instantiation primitive; a demonstrated case constructs a java.io.File for an arbitrary attacker-chosen path, which becomes path-traversal-adjacent if the application subsequently calls path-sensitive methods on the value. No class implementing Comparable has been identified that yields code execution through deserialization alone. Global Default Typing via activateDefaultTyping is not affected, because that method structurally requires an explicit PolymorphicTypeValidator argument. This affects com.fasterxml.jackson.core:jackson-databind from 2.11.0 before 2.18.10, from 2.19.0 before 2.21.6, and from 2.22.0 before 2.22.2, and tools.jackson.core:jackson-databind from 3.0.0 before 3.1.6 and from 3.2.0 before 3.2.2. Users should upgrade to 2.18.10, 2.21.6, 2.22.2, 3.1.6, or 3.2.2.

CVSS 5.6 · Media · EPSS 0,7% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • jackson-databind

    Versiones
    • ≥ 2.11.0, < 2.18.10: Afectada (maven)
    • ≥ 2.19.0, < 2.21.6: Afectada (maven)
    • ≥ 2.22.0, < 2.22.2: Afectada (maven)

    Actualiza a 2.18.10; Actualiza a 2.21.6; Actualiza a 2.22.2

  • jackson-databind

    Versiones
    • ≥ 3.0.0, < 3.1.6: Afectada (maven)
    • ≥ 3.2.0, < 3.2.2: Afectada (maven)

    Actualiza a 3.1.6; Actualiza a 3.2.2

  • jackson-databind Debian:12

    Versiones
    • 2.14.0+ds-1
    • 2.14.0+ds-2
    • 2.14.0+ds-3
    • 2.14.0-1
    • 2.14.0-1+deb12u1
    • 2.18.11-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jackson-databind Debian:13

    Versiones
    • 2.14.0+ds-1
    • 2.14.0+ds-1+deb13u1
    • 2.14.0+ds-2
    • 2.14.0+ds-3
    • 2.18.11-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jackson-databind Debian:14

    Versiones
    • 2.14.0+ds-1
    • 2.14.0+ds-2
    • 2.14.0+ds-3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.18.11-1

    Actualiza a 2.18.11-1

  • jackson-databind Ubuntu:Pro:14.04:LTS

    Versiones
    • 2.2.2-1
    • 2.2.2-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jackson-databind Ubuntu:Pro:16.04:LTS

    Versiones
    • 2.4.2-2
    • 2.4.2-3
    • 2.4.2-3ubuntu0.1~esm1
    • 2.4.2-3ubuntu0.1~esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jackson-databind Ubuntu:18.04:LTS

    Versiones
    • 2.8.6-1
    • 2.9.1-1
    • 2.9.4-1
    • 2.9.5-1
    • 2.9.8-1~18.04
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jackson-databind Ubuntu:20.04:LTS

    Versiones
    • 2.9.9.3-1
    • 2.10.0-2
    • 2.10.1-1
    • 2.10.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jackson-databind Ubuntu:22.04:LTS

    Versiones
    • 2.12.1-1
    • 2.12.5-1
    • 2.13.0-1
    • 2.13.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jackson-databind Ubuntu:24.04:LTS

    Versiones
    • 2.14.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jackson-databind Ubuntu:26.10

    Versiones
    • 2.14.0+ds-1build1
    • 2.14.0+ds-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jackson-databind Ubuntu:26.04:LTS

    Versiones
    • 2.14.0+ds-1
    • 2.14.0+ds-1build1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →