CVE-2026-83605
CVE-2026-83605 · xmldom: Attribute name injection via setAttribute() bypasses requireWellFormed
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.14 and 0.9.11, and in xmldom version 0.6.0 and earlier, Element.setAttribute() calls the private _createAttribute(name) path without validating the attribute name, while Document.createAttribute(name) validates against QName. XMLSerializer.serializeToString() emits attribute names verbatim, and requireWellFormed: true did not validate them, so a crafted name can terminate the intended attribute and inject additional attributes, including event handlers, into browser-consumed output; synthesized xmlns:PREFIX declarations expose the same unchecked-name boundary. This issue is fixed in @xmldom/xmldom versions 0.8.14 and 0.9.11; no fixed version is available for xmldom.
CVSS 8.7 · Alta · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
xmldom
- Versiones
- <= 0.6.0: Afectada
Sin corrección publicada
xmldom
- Versiones
- >= 0.7.0, < 0.8.14: Afectada
- >= 0.9.0, < 0.9.11: Afectada
Sin corrección publicada
node-xmldom Debian:12
- Versiones
- 0.8.6-1
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.5-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Debian:13
- Versiones
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Debian:14
- Versiones
- 0.9.10-1
- 0.9.10-2
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.9.11-1
Actualiza a 0.9.11-1
@xmldom/xmldom npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.9.0, < 0.9.11
Actualiza a 0.9.11
@xmldom/xmldom npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.7.0, < 0.8.14
Actualiza a 0.8.14
xmldom npm
- Intervalos de versiones afectados
- SEMVER: ≤ 0.6.0
Sin corrección publicada
node-xmldom Ubuntu:20.04:LTS
- Versiones
- 0.1.27+ds-1
- 0.1.27+ds-1+deb10u2build0.20.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Ubuntu:22.04:LTS
- Versiones
- 0.5.0-1
- 0.7.3-1
- 0.7.5-1
- 0.7.5-1ubuntu0.22.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Ubuntu:24.04:LTS
- Versiones
- 0.8.6-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Ubuntu:26.04:LTS
- Versiones
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/xmldom/xmldom/security/advisories/GHSA-4w3w-2rp5-g8jm
- https://github.com/xmldom/xmldom/pull/1043
- https://github.com/xmldom/xmldom/pull/1050
- https://github.com/xmldom/xmldom/commit/cba1321218b069182695813fa7565653708e172e
- https://github.com/xmldom/xmldom/commit/d8212e632507eaf1d9f609657dd4c56abeb12d44
- https://github.com/xmldom/xmldom/releases/tag/0.8.14
- https://github.com/xmldom/xmldom/releases/tag/0.9.11
- https://nvd.nist.gov/vuln/detail/CVE-2026-83605