p PatchFirst

CVE-2026-83609

CVE-2026-83609 · xmldom: Creation-time XML Name/QName validation is bypassable via an embedded line terminator, allowing injection on the default serialization path

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. From 0.9.0 until 0.9.12, the shared reg() builder in lib/grammar.js compiles the anchored QName_exact validator with the multiline flag, so ^ and $ validate only one line instead of the complete name. createElementNS, createAttributeNS, createDocumentType, and createAttribute consequently accept a malformed XML name whose first line is valid and whose later text injects markup when serialized through either the default path or requireWellFormed: true. The triggering ECMAScript line terminators are U+000A, U+000D, U+2028, and U+2029. This issue is fixed in @xmldom/xmldom version 0.9.12.

CVSS 8.7 · Alta · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • xmldom

    Versiones
    • >= 0.9.0, < 0.9.12: Afectada

    Sin corrección publicada

  • node-xmldom Debian:12

    Versiones
    • 0.8.6-1
    • 0.9.10-1
    • 0.9.10-2
    • 0.9.11-1
    • 0.9.12-1
    • 0.9.5-1
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    • 0.9.9-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-xmldom Debian:13

    Versiones
    • 0.9.10-1
    • 0.9.10-2
    • 0.9.11-1
    • 0.9.12-1
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    • 0.9.9-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-xmldom Debian:14

    Versiones
    • 0.9.10-1
    • 0.9.10-2
    • 0.9.11-1
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    • 0.9.9-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.9.12-1

    Actualiza a 0.9.12-1

  • @xmldom/xmldom npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 0.9.0, < 0.9.12

    Actualiza a 0.9.12

  • node-xmldom Ubuntu:20.04:LTS

    Versiones
    • 0.1.27+ds-1
    • 0.1.27+ds-1+deb10u2build0.20.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-xmldom Ubuntu:22.04:LTS

    Versiones
    • 0.5.0-1
    • 0.7.3-1
    • 0.7.5-1
    • 0.7.5-1ubuntu0.22.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-xmldom Ubuntu:24.04:LTS

    Versiones
    • 0.8.6-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-xmldom Ubuntu:26.10

    Versiones
    • 0.9.8-2
    • 0.9.10-2
    • 0.9.11-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-xmldom Ubuntu:26.04:LTS

    Versiones
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →