CVE-2026-83616
CVE-2026-83616 · xmldom: Processing Instruction Target Injection Bypasses requireWellFormed
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.15 and 0.9.12, and in xmldom version 0.6.0 and earlier, Document.createProcessingInstruction(target, data) in lib/dom.js accepts an unvalidated target, while the requireWellFormed: true serializer checks only for a colon and the reserved case-insensitive xml name on 0.9.x and performs no target check on 0.8.x. Because serialization emits <?target data?>, a target containing >, ?, whitespace, or another invalid XML-name character can break the processing-instruction boundary and inject XML structure. This issue is fixed in @xmldom/xmldom versions 0.8.15 and 0.9.12; no fixed version is available for xmldom.
CVSS 8.7 · Alta · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
xmldom
- Versiones
- <= 0.6.0: Afectada
Sin corrección publicada
xmldom
- Versiones
- >= 0.7.0, < 0.8.15: Afectada
- >= 0.9.0, < 0.9.12: Afectada
Sin corrección publicada
node-xmldom Debian:12
- Versiones
- 0.8.6-1
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.5-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Debian:13
- Versiones
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Debian:14
- Versiones
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.9.12-1
Actualiza a 0.9.12-1
@xmldom/xmldom npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.7.0, < 0.8.15
Actualiza a 0.8.15
@xmldom/xmldom npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.9.0, < 0.9.12
Actualiza a 0.9.12
xmldom npm
- Intervalos de versiones afectados
- SEMVER: ≤ 0.6.0
Sin corrección publicada
node-xmldom Ubuntu:20.04:LTS
- Versiones
- 0.1.27+ds-1
- 0.1.27+ds-1+deb10u2build0.20.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Ubuntu:22.04:LTS
- Versiones
- 0.5.0-1
- 0.7.3-1
- 0.7.5-1
- 0.7.5-1ubuntu0.22.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Ubuntu:24.04:LTS
- Versiones
- 0.8.6-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Ubuntu:26.10
- Versiones
- 0.9.8-2
- 0.9.10-2
- 0.9.11-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-xmldom Ubuntu:26.04:LTS
- Versiones
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/xmldom/xmldom/security/advisories/GHSA-c7q8-3ch8-vqpv
- https://github.com/xmldom/xmldom/pull/1071
- https://github.com/xmldom/xmldom/pull/1072
- https://github.com/xmldom/xmldom/commit/1cde3e31a07c41c87cfd368d6946aa477f16b4f9
- https://github.com/xmldom/xmldom/commit/3b694872bcb5c7e3cbadba961a4be2488750ce5b
- https://github.com/xmldom/xmldom/releases/tag/0.8.15
- https://github.com/xmldom/xmldom/releases/tag/0.9.12
- https://nvd.nist.gov/vuln/detail/CVE-2026-83616