CVE-2026-84372
CVE-2026-84372 · Predis: Redis command injection and denial of service via CRLF smuggling in pipelined commands on aggregate connections
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Predis is a flexible and feature-complete Redis and Valkey client for PHP. From version 3.0.0-RC1 until version 3.3.0, pipeline handling on aggregate cluster and replication connections reparses an already serialized RESP buffer in AbstractAggregateConnection::write() by splitting it with explode("\r\n") instead of honoring RESP length prefixes. Attacker-controlled keys or values containing CRLF sequences can therefore be interpreted by Command::deserializeCommand() as additional commands. On cluster connections, ClusterStrategy::getFakeKey() can route injected keyless commands using the literal fake key value "key", permitting operations such as shard-wide cache deletion, targeted data modification, data reads, or node disruption. On replication connections, malformed reparsing can throw an uncaught exception and repeatedly terminate affected requests. Only pipeline() reaches this vulnerable path; transaction() and MULTI are not affected. This issue is fixed in version 3.3.0.
CVSS 9.8 · Crítica · EPSS 0,7% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
predis
- Versiones
- >= 3.0.0-RC1, < 3.3.0: Afectada
Sin corrección publicada
predis/predis Packagist
- Versiones
- v3.0.0
- v3.0.0-RC1
- v3.0.1
- v3.1.0
- v3.2.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.0.0-RC1, < 3.3.0
Actualiza a 3.3.0
php-nrk-predis Ubuntu:16.04:LTS
- Versiones
- 1.0.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-nrk-predis Ubuntu:18.04:LTS
- Versiones
- 1.0.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-nrk-predis Ubuntu:20.04:LTS
- Versiones
- 1.0.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-nrk-predis Ubuntu:22.04:LTS
- Versiones
- 1.0.0-1
- 1.1.9-5
- 1.1.10-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-nrk-predis Ubuntu:24.04:LTS
- Versiones
- 2.2.0-1
- 2.2.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-nrk-predis Ubuntu:26.10
- Versiones
- 2.4.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-nrk-predis Ubuntu:26.04:LTS
- Versiones
- 2.4.0-1
- 2.4.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/predis/predis/security/advisories/GHSA-w6f5-v2h6-g786
- https://github.com/predis/predis/issues/1574
- https://github.com/predis/predis/pull/1586
- https://github.com/predis/predis/commit/053cb4b6ac7fb1f469ead96a78d059bc0458e408
- https://github.com/predis/predis/releases/tag/v3.3.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-84372