p PatchFirst

CVE-2026-87908

CVE-2026-87908 · multiparty vulnerable to Denial of Service via unbounded part-header accumulation

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

multiparty is a Node.js library for parsing multipart/form-data request bodies. In versions from 2.1.0 up to but not including 4.3.1, the parser does not bound the amount of memory used while accumulating the headers of a single multipart part. An unauthenticated attacker can send a single request whose part carries a very large volume of header bytes, forcing the parser to buffer all of them and exhausting the process memory, which crashes the server. This is a denial of service with no confidentiality or integrity impact. The issue is fixed in multiparty 4.3.1, which caps the size of the accumulated part headers. Users should upgrade to multiparty 4.3.1 or later.

CVSS 7.5 · Alta · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • multiparty

    Versiones
    • ≥ 2.1.0, < 4.3.1: Afectada (semver)
    • 4.3.1: No afectada (semver)

    Actualiza a 4.3.1

  • node-multiparty Debian:12

    Versiones
    • 4.2.3-2
    • 4.2.3-3
    • 4.2.3-4
    • 4.2.3-5
    • 4.3.0+~4.2.1-1
    • 4.3.0-1
    • 4.3.1+~4.2.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-multiparty Debian:13

    Versiones
    • 4.2.3-3
    • 4.2.3-4
    • 4.2.3-5
    • 4.3.0+~4.2.1-1
    • 4.3.0-1
    • 4.3.1+~4.2.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-multiparty Debian:14

    Versiones
    • 4.2.3-3
    • 4.2.3-4
    • 4.2.3-5
    • 4.3.0+~4.2.1-1
    • 4.3.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.3.1+~4.2.1-1

    Actualiza a 4.3.1+~4.2.1-1

  • node-multiparty Ubuntu:16.04:LTS

    Versiones
    • 4.0.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-multiparty Ubuntu:18.04:LTS

    Versiones
    • 4.0.0-1
    • 4.0.0-1ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-multiparty Ubuntu:20.04:LTS

    Versiones
    • 4.2.1-1
    • 4.2.1-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-multiparty Ubuntu:22.04:LTS

    Versiones
    • 4.2.2-2
    • 4.2.2-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-multiparty Ubuntu:24.04:LTS

    Versiones
    • 4.2.3-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-multiparty Ubuntu:26.10

    Versiones
    • 4.2.3-5
    • 4.3.0+~4.2.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-multiparty Ubuntu:26.04:LTS

    Versiones
    • 4.2.3-3
    • 4.2.3-4build1
    • 4.2.3-5
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →