p PatchFirst

CVE-2026-90711

CVE-2026-90711 · proxy-addr vulnerable to IP spoofing via IPv4-mapped IPv6 trust subnet

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

proxy-addr is a Node.js module that determines a request's client address behind trusted reverse proxies, and it backs Express req.ip and req.ips. In versions 1.1.0 through 2.0.7, a trust subnet written in IPv4-mapped IPv6 notation with an IPv4-sized prefix, such as ::ffff:10.0.0.0/8 instead of the correct ::ffff:10.0.0.0/104, is accepted without error but trusts every IPv4 address on the internet rather than the block it names. Because the socket peer then becomes trusted at hop 0, any unauthenticated client can supply an arbitrary X-Forwarded-For header and control the address the application reads, which defeats IP-based access control, rate limiting, geolocation, and audit logging. This is a fail-open regression introduced in version 1.1.0. The issue is fixed in proxy-addr 2.0.8, and users should upgrade to 2.0.8 or later. As a workaround, ensure any IPv4-mapped IPv6 trust subnet uses a prefix length of at least 97, or express the range in plain IPv4 notation.

CVSS 9.1 · Crítica · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • proxy-addr

    Versiones
    • ≥ 1.1.0, < 2.0.8: Afectada (semver)
    • 2.0.8: No afectada (semver)

    Actualiza a 2.0.8

  • node-proxy-addr Debian:12

    Versiones
    • 2.0.7+~cs2.3.0-1
    • 2.0.7+~cs2.3.7-1
    • 2.0.8+~cs2.3.7-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-proxy-addr Debian:13

    Versiones
    • 2.0.7+~cs2.3.0-1
    • 2.0.7+~cs2.3.7-1
    • 2.0.8+~cs2.3.7-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-proxy-addr Debian:14

    Versiones
    • 2.0.7+~cs2.3.0-1
    • 2.0.7+~cs2.3.7-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.0.8+~cs2.3.7-1

    Actualiza a 2.0.8+~cs2.3.7-1

  • proxy-addr npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 1.1.0, < 2.0.8

    Actualiza a 2.0.8

  • node-proxy-addr Ubuntu:16.04:LTS

    Versiones
    • 1.0.3-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-proxy-addr Ubuntu:18.04:LTS

    Versiones
    • 1.0.3-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-proxy-addr Ubuntu:20.04:LTS

    Versiones
    • 1.0.3-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-proxy-addr Ubuntu:22.04:LTS

    Versiones
    • 2.0.6+~0.1.2-1
    • 2.0.7+~cs2.3.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-proxy-addr Ubuntu:24.04:LTS

    Versiones
    • 2.0.7+~cs2.3.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-proxy-addr Ubuntu:26.10

    Versiones
    • 2.0.7+~cs2.3.7-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-proxy-addr Ubuntu:26.04:LTS

    Versiones
    • 2.0.7+~cs2.3.0-1
    • 2.0.7+~cs2.3.7-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →