CVE-2026-93337
CVE-2026-93337 · NetworkManager-l2tp Privilege Escalation via pppd Plugin Injection
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains an improper input validation vulnerability that allows local users with VPN connection creation permissions to inject arbitrary pppd directives by supplying mru or mtu property values containing trailing non-numeric content after a valid integer. Attackers can exploit the verbatim write of unvalidated strings into the pppd options file via write_config_option() to inject the plugin directive, causing the privileged pppd process to load an attacker-controlled shared object and achieve arbitrary code execution as root.
CVSS 8.5 · Alta · EPSS 0,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
networkmanager-l2tp
- Versiones
- ≥ 0, ≤ 1.52.4: Afectada (semver)
- 1.52.6: No afectada (semver)
Actualiza a 1.52.6
network-manager-l2tp Debian:12
- Versiones
- 1.20.8-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.20.8-1+deb12u1
Actualiza a 1.20.8-1+deb12u1
network-manager-l2tp Debian:13
- Versiones
- 1.20.20-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.20.20-2+deb13u1
Actualiza a 1.20.20-2+deb13u1
network-manager-l2tp Debian:14
- Versiones
- 1.20.20-2
- 1.52.0-1
- 1.52.0-2
- 1.52.2-1
- 1.52.4-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.52.6-1
Actualiza a 1.52.6-1
network-manager-l2tp Ubuntu:18.04:LTS
- Versiones
- 1.2.8-1
- 1.2.8-2build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
network-manager-l2tp Ubuntu:20.04:LTS
- Versiones
- 1.2.10-1
- 1.2.14-1
- 1.2.16-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
network-manager-l2tp Ubuntu:22.04:LTS
- Versiones
- 1.2.18-1build1
- 1.20.0-1
- 1.20.0-1build1
- 1.20.0-1build2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
network-manager-l2tp Ubuntu:24.04:LTS
- Versiones
- 1.20.8-1
- 1.20.10-1
- 1.20.12-1
- 1.20.12-1build1
- 1.20.12-1build2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
network-manager-l2tp Ubuntu:26.04:LTS
- Versiones
- 1.20.20-2
- 1.52.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/nm-l2tp/NetworkManager-l2tp/security/advisories/GHSA-rp84-8h2r-5xc3
- https://github.com/nm-l2tp/NetworkManager-l2tp/commit/64879ce0ad866f7c9a45babe4d95731a916ea00f
- https://www.vulncheck.com/advisories/networkmanager-l2tp-privilege-escalation-via-pppd-plugin-injection
- https://nvd.nist.gov/vuln/detail/CVE-2026-93337