CVE-2026-93421
CVE-2026-93421 · Mesop: Unauthenticated ANSI Escape Sequence Injection in CSP Reporting Endpoint
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Mesop is a Python-based UI framework that allows users to build web applications. Prior to 1.3.4, the unauthenticated /__csp__ endpoint passes attacker-controlled document-uri, blocked-uri, and violated-directive values to the csp_report handler in mesop/server/static_file_serving.py, which prints them to standard output without neutralizing terminal control sequences. When an operator views the resulting logs in an ANSI-capable terminal, injected ANSI or VT100 sequences can clear or reposition the display, hide text, or present forged messages, reducing the integrity of monitoring and incident-response output. This issue is fixed in version 1.3.4.
CVSS 5.3 · Media · EPSS 0,5% · Código de explotación público · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
mesop
- Versiones
- < 1.3.4: Afectada
Sin corrección publicada
mesop PyPI
- Versiones
- 0.0.1
- 0.10.0
- 0.10.0rc0
- 0.10.0rc1
- 0.10.0rc2
- 0.11.0
- 0.11.0rc0
- 0.11.1
- 0.12.0
- 0.12.0rc0
- 0.12.1
- 0.12.10b1
- 0.12.10b2
- 0.12.10b3
- 0.12.10rc1
- 0.12.1rc0
- 0.12.2
- 0.12.3
- 0.12.3rc0
- 0.12.4
- 0.12.4rc0
- 0.12.5
- 0.12.5b1
- 0.12.5rc1
- 0.12.6
- 0.12.6rc1
- 0.12.7
- 0.12.7b1
- 0.12.7rc1
- 0.12.8
- 0.12.8b1
- 0.12.8rc1
- 0.12.9
- 0.12.9rc1
- 0.13.0
- 0.13.0rc1
- 0.14.0
- 0.14.1
- 0.14.1rc1
- 0.14.2b1
- 0.14.2b2
- 0.14.2rc1
- 0.14rc1
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.4.0
- 0.4.1
- 0.4.2
- 0.5.0
- 0.5.1
- 0.5.2
- 0.5.3
- 0.5.4
- 0.5.5
- 0.5.6
- 0.6.0
- 0.7.0
- 0.7.1
- 0.7.2
- 0.8.0
- 0.8.0rc0
- 0.9.0
- 0.9.0rc1
- 0.9.1
- 0.9.1rc1
- 0.9.2
- 0.9.2rc1
- 0.9.3
- 0.9.3rc0
- 0.9.4
- 0.9.4rc0
- 0.9.5
- 0.9.5rc0
- 1.0.0
- 1.0.0rc1
- 1.0.0rc2
- 1.0.1
- 1.0.1rc1
- 1.1.0
- 1.1.0rc1
- 1.1.1
- 1.1.1rc1
- 1.1.1rc2
- 1.1.1rc3
- 1.2.0
- 1.2.0rc1
- 1.2.1
- 1.2.1rc1
- 1.2.2
- 1.2.2rc1
- 1.2.3
- 1.2.4rc1
- 1.2.5
- 1.2.5rc1
- 1.2.6rc2
- 1.2.7
- 1.2.7rc1
- 1.3.0
- 1.3.0rc1
- 1.3.0rc2
- 1.3.2
- 1.3.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.3.4
Actualiza a 1.3.4
Fuentes originales
- https://github.com/mesop-dev/mesop/security/advisories/GHSA-g7f6-rxc4-qhph
- https://github.com/mesop-dev/mesop/pull/1397
- https://github.com/mesop-dev/mesop/commit/f38c42a1d3eba246941ef8d7f645072d53c58785
- https://github.com/mesop-dev/mesop/releases/tag/v1.3.4
- https://nvd.nist.gov/vuln/detail/CVE-2026-93421