CVE-2026-97380
CVE-2026-97380 · MariaDB: GRANT PROXY with empty password incorrectly checks grantor's privileges
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the GRANT PROXY statement treats an IDENTIFIED clause with an empty password as though authentication were not specified, causing it to check the wrong grantor privileges. A low-privileged attacker who can name another account can exploit this authorization error to set that account's password. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVSS 8.8 · Alta · EPSS 1,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · database
Productos y versiones afectados
server
- Versiones
- >= 10.6.1, < 10.6.28: Afectada
- >= 10.11.1, < 10.11.19: Afectada
- >= 11.4.1, < 11.4.13: Afectada
- >= 11.8.1, < 11.8.9: Afectada
- >= 12.3.1, < 12.3.3: Afectada
- >= 13.0.1, < 13.0.2: Afectada
Sin corrección publicada
mariadb Debian:12
- Versiones
- 1:10.11.11-0+deb12u1
- 1:10.11.13-0+deb12u1
- 1:10.11.14-0+deb12u1
- 1:10.11.14-0+deb12u2
- 1:10.11.18-0+deb12u1
- 1:10.11.19-0+deb12u1
- 1:10.11.3-1
- 1:10.11.3-2~exp1
- 1:10.11.4-1
- 1:10.11.4-1~deb12u1
- 1:10.11.5-1
- 1:10.11.5-2
- 1:10.11.5-3
- 1:10.11.6-0+deb12u1
- 1:10.11.6-1
- 1:10.11.6-2
- 1:10.11.6-2.1~exp1
- 1:10.11.7-1
- 1:10.11.7-2
- 1:10.11.7-3
- 1:10.11.7-4
- 1:10.11.8-1
- 1:10.11.9-0+deb12u1
- 1:11.4.2-1
- 1:11.4.2-2
- 1:11.4.2-3
- 1:11.4.2-4
- 1:11.4.3-1
- 1:11.4.4-1
- 1:11.4.4-2
- 1:11.4.4-3
- 1:11.4.5-1
- 1:11.4.5-2~exp1
- 1:11.8.1-1
- 1:11.8.1-2
- 1:11.8.1-3
- 1:11.8.1-4
- 1:11.8.1-5
- 1:11.8.2-1
- 1:11.8.3-1
- 1:11.8.5-1
- 1:11.8.5-2
- 1:11.8.5-3
- 1:11.8.5-3~exp1
- 1:11.8.5-3~exp2
- 1:11.8.5-3~exp3
- 1:11.8.5-4
- 1:11.8.6-1
- 1:11.8.6-2
- 1:11.8.6-3
- 1:11.8.6-4
- 1:11.8.6-5
- 1:11.8.6-6
- 1:11.8.8-1
- 1:11.8.9+ds-1
- 1:11.8.9+ds-2
- 1:11.8.9+ds-3
- 1:11.8.9+ds-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mariadb Debian:13
- Versiones
- 1:11.8.2-1
- 1:11.8.3-0+deb13u1
- 1:11.8.3-1
- 1:11.8.5-1
- 1:11.8.5-2
- 1:11.8.5-3
- 1:11.8.5-3~exp1
- 1:11.8.5-3~exp2
- 1:11.8.5-3~exp3
- 1:11.8.5-4
- 1:11.8.6-0+deb13u1
- 1:11.8.6-1
- 1:11.8.6-2
- 1:11.8.6-3
- 1:11.8.6-4
- 1:11.8.6-5
- 1:11.8.6-6
- 1:11.8.8-0+deb13u1
- 1:11.8.8-1
- 1:11.8.9+ds-1
- 1:11.8.9+ds-2
- 1:11.8.9+ds-3
- 1:11.8.9+ds-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mariadb Debian:14
- Versiones
- 1:11.8.2-1
- 1:11.8.3-1
- 1:11.8.5-1
- 1:11.8.5-2
- 1:11.8.5-3
- 1:11.8.5-3~exp1
- 1:11.8.5-3~exp2
- 1:11.8.5-3~exp3
- 1:11.8.5-4
- 1:11.8.6-1
- 1:11.8.6-2
- 1:11.8.6-3
- 1:11.8.6-4
- 1:11.8.6-5
- 1:11.8.6-6
- 1:11.8.8-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:11.8.9+ds-1
Actualiza a 1:11.8.9+ds-1
mariadb-10.0 Ubuntu:16.04:LTS
- Versiones
- 10.0.20-0ubuntu0.15.04.1
- 10.0.22-0ubuntu1
- 10.0.23-1
- 10.0.23-2
- 10.0.24-7
- 10.0.25-0ubuntu0.16.04.1
- 10.0.27-0ubuntu0.16.04.1
- 10.0.28-0ubuntu0.16.04.1
- 10.0.29-0ubuntu0.16.04.1
- 10.0.31-0ubuntu0.16.04.2
- 10.0.33-0ubuntu0.16.04.1
- 10.0.34-0ubuntu0.16.04.1
- 10.0.36-0ubuntu0.16.04.1
- 10.0.38-0ubuntu0.16.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mariadb-10.1 Ubuntu:18.04:LTS
- Versiones
- 10.1.25-1
- 1:10.1.29-6
- 1:10.1.34-0ubuntu0.18.04.1
- 1:10.1.38-0ubuntu0.18.04.1
- 1:10.1.38-0ubuntu0.18.04.2
- 1:10.1.40-0ubuntu0.18.04.1
- 1:10.1.41-0ubuntu0.18.04.1
- 1:10.1.43-0ubuntu0.18.04.1
- 1:10.1.44-0ubuntu0.18.04.1
- 1:10.1.47-0ubuntu0.18.04.1
- 1:10.1.48-0ubuntu0.18.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mariadb-10.3 Ubuntu:20.04:LTS
- Versiones
- 1:10.3.17-1
- 1:10.3.18-1
- 1:10.3.19-1
- 1:10.3.21-2
- 1:10.3.22-1
- 1:10.3.22-1ubuntu1
- 1:10.3.25-0ubuntu0.20.04.1
- 1:10.3.29-0ubuntu0.20.04.1
- 1:10.3.30-0ubuntu0.20.04.1
- 1:10.3.31-0ubuntu0.20.04.1
- 1:10.3.32-0ubuntu0.20.04.1
- 1:10.3.34-0ubuntu0.20.04.1
- 1:10.3.37-0ubuntu0.20.04.1
- 1:10.3.38-0ubuntu0.20.04.1
- 1:10.3.39-0ubuntu0.20.04.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mariadb-10.6 Ubuntu:22.04:LTS
- Versiones
- 1:10.6.7-2ubuntu1
- 1:10.6.7-2ubuntu1.1
- 1:10.6.11-0ubuntu0.22.04.1
- 1:10.6.12-0ubuntu0.22.04.1
- 1:10.6.16-0ubuntu0.22.04.1
- 1:10.6.18-0ubuntu0.22.04.1
- 1:10.6.21-0ubuntu0.22.04.2
- 1:10.6.22-0ubuntu0.22.04.1
- 1:10.6.23-0ubuntu0.22.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mariadb Ubuntu:24.04:LTS
- Versiones
- 1:10.11.4-1
- 1:10.11.5-3
- 1:10.11.6-1
- 1:10.11.6-2
- 1:10.11.7-2ubuntu1
- 1:10.11.7-2ubuntu2
- 1:10.11.8-0ubuntu0.24.04.1
- 1:10.11.11-0ubuntu0.24.04.2
- 1:10.11.13-0ubuntu0.24.04.1
- 1:10.11.14-0ubuntu0.24.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mariadb Ubuntu:26.10
- Versiones
- 1:11.8.6-5
- 1:11.8.8-1
- 1:11.8.9+ds-4ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mariadb Ubuntu:26.04:LTS
- Versiones
- 1:11.8.3-1build1
- 1:11.8.5-1
- 1:11.8.5-2
- 1:11.8.5-3
- 1:11.8.5-4
- 1:11.8.6-1
- 1:11.8.6-3
- 1:11.8.6-4
- 1:11.8.6-5
- 1:11.8.6-5ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/MariaDB/server/security/advisories/GHSA-625w-4hgq-qwmr
- https://github.com/MariaDB/server/commit/dbd60d0ad8daa2d01050346aa50b7b102490e456
- https://github.com/MariaDB/server/releases/tag/mariadb-10.11.19
- https://github.com/MariaDB/server/releases/tag/mariadb-10.6.28
- https://github.com/MariaDB/server/releases/tag/mariadb-11.4.13
- https://github.com/MariaDB/server/releases/tag/mariadb-11.8.9
- https://github.com/MariaDB/server/releases/tag/mariadb-12.3.3
- https://github.com/MariaDB/server/releases/tag/mariadb-13.0.2
- https://jira.mariadb.org/browse/MDEV-40470
- https://nvd.nist.gov/vuln/detail/CVE-2026-97380