p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de nss

Vulnerabilidades publicadas para nss en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 85

  1. CVE-2026-6772

    Alta · CVSS 7.5EPSS 0,39%Corrección disponible

    Incorrect boundary conditions in the Libraries component in NSS

    Incorrect boundary conditions in the Libraries component in NSS. This vulnerability was fixed in Firefox 150, Firefox ESR 115.35, Firefox ESR 140.10, Thunderbird 150, and Thunderbird 140.10.

    • Actualiza a 2:3.87.1-1+deb12u3
    Publicación Actualización
  2. CVE-2024-7531

    Media · CVSS 6.3EPSS 0,44%Sin corrección publicada

    CVE-2024-7531

    Calling `PK11_Encrypt()` in NSS using CKM_CHACHA20 and the same buffer for input and output can result in plaintext on an Intel Sandy Bridge processor. In Firefox this only affects the QUIC header protection feature when the connection is using the ChaCha20-Poly1305 cipher suite. The most likely outcome is connection failure, but if the connection persists despite the high packet loss it could be possible for a network observer to identify packets as coming from the same source despite a network path change. This vulnerability affects Firefox < 129, Firefox ESR < 115.14, and Firefox ESR < 128.1.

    Publicación Actualización
  3. CVE-2023-5388

    Media · CVSS 6.5EPSS 0,97%Sin corrección publicada

    CVE-2023-5388

    NSS was susceptible to a timing side-channel attack when performing RSA decryption. This attack could potentially allow an attacker to recover the private data. This vulnerability affects Firefox < 124, Firefox ESR < 115.9, and Thunderbird < 115.9.

    Publicación Actualización
  4. CVE-2023-4421

    Media · CVSS 6.5EPSS 0,76%Corrección disponible

    CVE-2023-4421

    The NSS code used for checking PKCS#1 v1.5 was leaking information useful in mounting Bleichenbacher-like attacks. Both the overall correctness of the padding as well as the length of the encrypted message was leaking through timing side-channel. By sending large number of attacker-selected ciphertexts, the attacker would be able to decrypt a previously intercepted PKCS#1 v1.5 ciphertext (for example, to decrypt a TLS session that used RSA key exchange), or forge a signature using the victim's key. The issue was fixed by implementing the implicit rejection algorithm, in which the NSS returns a deterministic random message in case invalid padd

    • Actualiza a 2:3.61-1
    Publicación Actualización
  5. CVE-2023-0767

    Alta · CVSS 8.8EPSS 0,82%Corrección disponible

    CVE-2023-0767

    An attacker could construct a PKCS 12 cert bundle in such a way that could allow for arbitrary memory writes via PKCS 12 Safe Bag attributes being mishandled. This vulnerability affects Firefox < 110, Thunderbird < 102.8, and Firefox ESR < 102.8.

    • Actualiza a 2:3.87.1-1
    Publicación Actualización
  6. CVE-2022-22747

    Media · CVSS 6.5EPSS 0,67%Corrección disponible

    CVE-2022-22747

    After accepting an untrusted certificate, handling an empty pkcs7 sequence as part of the certificate data could have lead to a crash. This crash is believed to be unexploitable. This vulnerability affects Firefox ESR < 91.5, Firefox < 96, and Thunderbird < 91.5.

    • Actualiza a 2:3.73-1
    Publicación Actualización
  7. CVE-2021-43527

    Crítica · CVSS 9.8EPSS 17,56%Corrección disponible

    CVE-2021-43527

    NSS (Network Security Services) versions prior to 3.73 or 3.68.1 ESR are vulnerable to a heap overflow when handling DER-encoded DSA or RSA-PSS signatures. Applications using NSS for handling signatures encoded within CMS, S/MIME, PKCS \#7, or PKCS \#12 are likely to be impacted. Applications using NSS for certificate validation or other TLS, X.509, OCSP or CRL functionality may be impacted, depending on how they configure NSS. *Note: This vulnerability does NOT impact Mozilla Firefox.* However, email clients and PDF viewers that use NSS for signature verification, such as Thunderbird, LibreOffice, Evolution and Evince are believed to be impa

    • Actualiza a 2:3.73-1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →