p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de bcel

Vulnerabilidades publicadas para bcel en los últimos 30 días: 2. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 4

  1. CVE-2026-105111

    Baja · CVSS 2.3EPSS 0,25%Sin corrección publicada

    Apache Commons BCEL: Class2HTML emits unescaped class strings, enabling stored XSS

    Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Commons BCEL. This only happens when you're using Class2HTML to generate webpages for possibly-attacker-controlled class files, where Class2HTML emitters write attacker class-file strings into HTML unescaped (stored XSS in reports). This issue affects Apache Commons BCEL: before 6.13.0. Users are recommended to upgrade to version 6.13.0, which fixes the issue.

    Publicación Actualización
  2. CVE-2026-94114

    Alta · CVSS 8.2EPSS 0,28%Sin corrección publicada

    Apache Commons BCEL: Class repositories cache class files under their self-declared names, enabling cache poisoning

    Symbolic name not mapping to correct class. BCEL caches attacker-controlled classes under their self-declared names without validating the requested name, allowing subsequent lookups and name-keyed verification results to refer to a different class. This issue affects Apache Commons BCEL: before 6.13.0. Users are recommended to upgrade to version 6.13.0, which fixes the issue.

    Publicación Actualización
  3. CVE-2022-42920

    Crítica · CVSS 9.8EPSS 2,81%Corrección disponible

    Apache Commons BCEL prior to 6.6.0 allows producing arbitrary bytecode via out-of-bounds writing

    Apache Commons BCEL has a number of APIs that would normally only allow changing specific class characteristics. However, due to an out-of-bounds writing issue, these APIs can be used to produce arbitrary bytecode. This could be abused in applications that pass attacker-controllable data to those APIs, giving the attacker more control over the resulting bytecode than otherwise expected. Update to Apache Commons BCEL 6.6.0.

    • Actualiza a 6.5.0-2
    Publicación Actualización
  4. CVE-2022-34169

    Alta · CVSS 7.5EPSS 81,76%Corrección disponible

    Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets

    The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. Users are recommended to update to version 2.7.3 or later. Note: Java runtimes (such as OpenJDK) include repackaged copies of Xalan.

    • Actualiza a 6.5.0-2
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →