p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ffmpeg · Página 5

Vulnerabilidades publicadas para ffmpeg en los últimos 30 días: 10. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 433

  1. CVE-2023-6603

    Alta · CVSS 7.5EPSS 0,58%Corrección disponible

    Ffmpeg: null pointer dereference in ffmpeg hls parsing

    A flaw was found in FFmpeg's HLS playlist parsing. This vulnerability allows a denial of service via a maliciously crafted HLS playlist that triggers a null pointer dereference during initialization.

    • Actualiza a 7:5.0.1-2
    Publicación Actualización
  2. CVE-2024-36615

    Media · CVSS 5.9EPSS 0,44%Corrección disponible

    CVE-2024-36615

    FFmpeg n7.0 has a race condition vulnerability in the VP9 decoder. This could lead to a data race if video encoding parameters were being exported, as the side data would be attached in the decoder thread while being read in the output thread.

    • Actualiza a 7:7.1-3
    Publicación Actualización
  3. CVE-2024-35369

    Media · CVSS 5.5EPSS 0,24%Corrección disponible

    CVE-2024-35369

    In FFmpeg version n6.1.1, specifically within the avcodec/speexdec.c module, a potential security vulnerability exists due to insufficient validation of certain parameters when parsing Speex codec extradata. This vulnerability could lead to integer overflow conditions, potentially resulting in undefined behavior or crashes during the decoding process.

    • Actualiza a 7:7.0.1-3
    Publicación Actualización
  4. CVE-2024-35366

    Crítica · CVSS 9.1EPSS 0,65%Corrección disponible

    CVE-2024-35366

    FFmpeg n6.1.1 is Integer Overflow. The vulnerability exists in the parse_options function of sbgdec.c within the libavformat module. When parsing certain options, the software does not adequately validate the input. This allows for negative duration values to be accepted without proper bounds checking.

    • Actualiza a 7:7.0.1-3
    Publicación Actualización
  5. CVE-2024-7272

    Media · CVSS 6.9EPSS 1,2%Corrección disponible

    FFmpeg swresample.c fill_audiodata heap-based overflow

    A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.

    • Actualiza a 7:6.0-4
    Publicación Actualización
  6. CVE-2024-7055

    Media · CVSS 6.9EPSS 1,44%Corrección disponible

    FFmpeg pnmdec.c pnm_decode_frame heap-based overflow

    A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.

    • Actualiza a 7:7.0.2-1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →