p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de jruby · Página 2

Vulnerabilidades publicadas para jruby en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 26

  1. CVE-2018-1000074

    Alta · CVSS 7.8EPSS 2,88%Corrección disponible

    CVE-2018-1000074

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.

    • Actualiza a 9.1.17.0-1
    Publicación Actualización
  2. CVE-2018-1000073

    Alta · CVSS 7.5EPSS 4,91%Corrección disponible

    CVE-2018-1000073

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.

    • Actualiza a 9.1.17.0-2.1
    Publicación Actualización
  3. CVE-2015-3900

    Sin evaluarEPSS 8,87%Corrección disponible

    CVE-2015-3900

    RubyGems 2.0.x before 2.0.16, 2.2.x before 2.2.4, and 2.4.x before 2.4.7 does not validate the hostname when fetching gems or making API requests, which allows remote attackers to redirect requests to arbitrary domains via a crafted DNS SRV record, aka a "DNS hijack attack."

    • Actualiza a 1.7.20.1-2
    Publicación Actualización
  4. CVE-2012-5370

    Sin evaluarEPSS 2,25%Corrección disponible

    CVE-2012-5370

    JRuby computes hash values without properly restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted input to an application that maintains a hash table, as demonstrated by a universal multicollision attack against the MurmurHash2 algorithm, a different vulnerability than CVE-2011-4838.

    • Actualiza a 1.5.6-5
    Publicación Actualización
  5. CVE-2010-1330

    Sin evaluarEPSS 2,22%Corrección disponible

    CVE-2010-1330

    The regular expression engine in JRuby before 1.4.1, when $KCODE is set to 'u', does not properly handle characters immediately after a UTF-8 character, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted string.

    • Actualiza a 1.5.0~rc1-1
    Publicación Actualización
  6. CVE-2011-4838

    Sin evaluarEPSS 4,2%Corrección disponible

    CVE-2011-4838

    JRuby before 1.6.5.1 computes hash values without restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted input to an application that maintains a hash table.

    • Actualiza a 1.5.6-4
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →