p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de libraw

Vulnerabilidades publicadas para libraw en los últimos 30 días: 1. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 63

  1. CVE-2026-111272

    Media · CVSS 6.8EPSS 0,13%Sin corrección publicada

    LibRaw through 0.22.2 Heap Out-of-Bounds Read via parseNikonMakernote ShotInfo

    LibRaw through 0.22.2 contains a heap-based out-of-bounds read in LibRaw::parseNikonMakernote() that allows attackers to read past a short ShotInfo buffer. Attackers can supply a crafted Nikon NEF/TIFF with a 5-byte ShotInfo tag declaring version 243 to crash applications decoding the image.

    Publicación Actualización
  2. CVE-2026-88387

    Media · CVSS 5.5EPSS 0,18%Sin corrección publicada

    CVE-2026-88387

    LibRaw 0.22.0 contains an incorrect numeric conversion vulnerability in LibRaw::parse_tiff_ifd() when processing TIFF tag 0x00fe (NewSubfileType). A specially crafted RAW, TIFF, or DNG file can supply an attacker-controlled NewSubfileType value outside the range of a signed int. The parser converts this value and narrows it to int without performing range validation. This out-of-range conversion triggers undefined behavior, resulting in process termination and denial of service.

    Publicación Actualización
  3. CVE-2026-21413

    Crítica · CVSS 9.8EPSS 1,38%Corrección disponible

    CVE-2026-21413

    A heap-based buffer overflow vulnerability exists in the lossless_jpeg_load_raw functionality of LibRaw Commit 0b56545 and Commit d20315b. A specially crafted malicious file can lead to a heap buffer overflow. An attacker can provide a malicious file to trigger this vulnerability.

    • Actualiza a 0.21.4-2+deb13u1
    Publicación Actualización
  4. CVE-2026-20889

    Crítica · CVSS 9.8EPSS 0,8%Corrección disponible

    CVE-2026-20889

    A heap-based buffer overflow vulnerability exists in the x3f_thumb_loader functionality of LibRaw Commit d20315b. A specially crafted malicious file can lead to a heap buffer overflow. An attacker can provide a malicious file to trigger this vulnerability.

    • Actualiza a 0.21.4-2+deb13u1
    Publicación Actualización
  5. CVE-2026-24660

    Alta · CVSS 8.1EPSS 0,7%Corrección disponible

    CVE-2026-24660

    A heap-based buffer overflow vulnerability exists in the x3f_load_huffman functionality of LibRaw Commit d20315b. A specially crafted malicious file can lead to a heap buffer overflow. An attacker can provide a malicious file to trigger this vulnerability.

    • Actualiza a 0.21.4-2+deb13u1
    Publicación Actualización
  6. CVE-2026-24450

    Alta · CVSS 8.1EPSS 0,57%Corrección disponible

    CVE-2026-24450

    An integer overflow vulnerability exists in the uncompressed_fp_dng_load_raw functionality of LibRaw Commit 8dc68e2. A specially crafted malicious file can lead to a heap buffer overflow. An attacker can provide a malicious file to trigger this vulnerability.

    • Actualiza a 0.21.4-2+deb13u1
    Publicación Actualización
  7. CVE-2026-20884

    Alta · CVSS 8.1EPSS 0,57%Corrección disponible

    CVE-2026-20884

    An integer overflow vulnerability exists in the deflate_dng_load_raw functionality of LibRaw Commit 8dc68e2. A specially crafted malicious file can lead to a heap buffer overflow. An attacker can provide a malicious file to trigger this vulnerability.

    • Actualiza a 0.21.4-2+deb13u1
    Publicación Actualización
  8. CVE-2026-5342

    Media · CVSS 6.9EPSS 0,73%Corrección disponible

    LibRaw TIFF/NEF decoders_libraw.cpp nikon_load_padded_packed_raw out-of-bounds

    A flaw has been found in LibRaw up to 0.22.0. This affects the function LibRaw::nikon_load_padded_packed_raw of the file src/decoders/decoders_libraw.cpp of the component TIFF/NEF. Executing a manipulation of the argument load_flags/raw_width can lead to out-of-bounds read. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 0.22.1 mitigates this issue. This patch is called b8397cd45657b84e88bd1202528d1764265f185c. It is advisable to upgrade the affected component.

    • Actualiza a 0.21.4-2+deb13u1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →