p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de spotipy

Vulnerabilidades publicadas para spotipy en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 2

  1. CVE-2025-66040

    Baja · CVSS 3.6EPSS 0,17%Sin corrección publicada

    Spotipy has a XSS vulnerability in OAuth callback server

    Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.

    Publicación Actualización
  2. CVE-2025-27154

    Alta · CVSS 8.4EPSS 0,61%Corrección disponible

    Spotipy's cache file, containing spotify auth token, is created with overly broad permissions

    Spotipy is a lightweight Python library for the Spotify Web API. The `CacheHandler` class creates a cache file to store the auth token. Prior to version 2.25.1, the file created has `rw-r--r--` (644) permissions by default, when it could be locked down to `rw-------` (600) permissions. This leads to overly broad exposure of the spotify auth token. If this token can be read by an attacker (another user on the machine, or a process running as another user), it can be used to perform administrative actions on the Spotify account, depending on the scope granted to the token. Version 2.25.1 tightens the cache file permissions.

    • Actualiza a 2.25.1-1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →