p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de pyjwt · Página 2

Vulnerabilidad publicada para pyjwt en los últimos 30 días: 1. En el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 23

  1. CVE-2025-45768

    Alta · CVSS 7EPSS 0,18%Corrección disponible

    CVE-2025-45768

    pyjwt v2.10.1 was discovered to contain weak encryption. NOTE: this is disputed by the Supplier because the key length is chosen by the application that uses the library (admittedly, library users may benefit from a minimum value and a mechanism for opting in to strict enforcement).

    • Actualiza a 2.11.0-2
    Publicación Actualización
  2. CVE-2022-29217

    Alta · CVSS 7.4EPSS 1,35%Corrección disponible

    Key confusion through non-blocklisted public key formats in PyJWT

    PyJWT is a Python implementation of RFC 7519. PyJWT supports multiple different JWT signing algorithms. With JWT, an attacker submitting the JWT token can choose the used signing algorithm. The PyJWT library requires that the application chooses what algorithms are supported. The application can specify `jwt.algorithms.get_default_algorithms()` to get support for all algorithms, or specify a single algorithm. The issue is not that big as `algorithms=jwt.algorithms.get_default_algorithms()` has to be used. Users should upgrade to v2.4.0 to receive a patch for this issue. As a workaround, always be explicit with the algorithms that are accepted

    • Actualiza a 2.4.0-1
    Publicación Actualización
  3. CVE-2017-11424

    Alta · CVSS 7.5EPSS 1,8%Corrección disponible

    CVE-2017-11424

    In PyJWT 1.5.0 and below the `invalid_strings` check in `HMACAlgorithm.prepare_key` does not account for all PEM encoded public keys. Specifically, the PKCS1 PEM encoded format would be allowed because it is prefaced with the string `-----BEGIN RSA PUBLIC KEY-----` which is not accounted for. This enables symmetric/asymmetric key confusion attacks against users using the PKCS1 PEM encoded public keys, which would allow an attacker to craft JWTs from scratch.

    • Actualiza a 1.4.2-1.1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →