CVE-2022-29217
CVE-2022-29217 · Key confusion through non-blocklisted public key formats in PyJWT
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
PyJWT is a Python implementation of RFC 7519. PyJWT supports multiple different JWT signing algorithms. With JWT, an attacker submitting the JWT token can choose the used signing algorithm. The PyJWT library requires that the application chooses what algorithms are supported. The application can specify `jwt.algorithms.get_default_algorithms()` to get support for all algorithms, or specify a single algorithm. The issue is not that big as `algorithms=jwt.algorithms.get_default_algorithms()` has to be used. Users should upgrade to v2.4.0 to receive a patch for this issue. As a workaround, always be explicit with the algorithms that are accepted and expected when decoding.
CVSS 7.4 · Alta · EPSS 1,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
pyjwt
- Versiones
- >= 1.5.0, < 2.4.0: Afectada
Sin corrección publicada
pyjwt Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.0-1
Actualiza a 2.4.0-1
pyjwt Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.0-1
Actualiza a 2.4.0-1
pyjwt Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.0-1
Actualiza a 2.4.0-1
pyjwt PyPI
- Versiones
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 1.6.0
- 1.6.1
- 1.6.3
- 1.6.4
- 1.7.0
- 1.7.1
- 2.0.0
- 2.0.0a1
- 2.0.0a2
- 2.0.1
- 2.1.0
- 2.2.0
- 2.3.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.5.0, < 2.4.0
Actualiza a 2.4.0
pyjwt PyPI
- Versiones
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 1.6.0
- 1.6.1
- 1.6.3
- 1.6.4
- 1.7.0
- 1.7.1
- 2.0.0
- 2.0.0a1
- 2.0.0a2
- 2.0.1
- 2.1.0
- 2.2.0
- 2.3.0
- Intervalos de versiones afectados
- GIT: < 9c528670c455b8d948aff95ed50e22940d1ad3fc
- ECOSYSTEM: ≥ 1.5.0, < 2.4.0
Actualiza a 2.4.0
pyjwt Ubuntu:18.04:LTS
- Versiones
- 1.4.2-1.1
- 1.5.3+ds1-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.5.3+ds1-1ubuntu0.1
Actualiza a 1.5.3+ds1-1ubuntu0.1
pyjwt Ubuntu:20.04:LTS
- Versiones
- 1.7.0-2
- 1.7.1-1
- 1.7.1-2ubuntu1
- 1.7.1-2ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.7.1-2ubuntu2.1
Actualiza a 1.7.1-2ubuntu2.1
pyjwt Ubuntu:22.04:LTS
- Versiones
- 1.7.1-2ubuntu2
- 2.1.0-1
- 2.3.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.3.0-1ubuntu0.1
Actualiza a 2.3.0-1ubuntu0.1
Fuentes originales
- https://github.com/jpadilla/pyjwt/security/advisories/GHSA-ffqj-6fqr-9h24
- https://github.com/jpadilla/pyjwt/commit/9c528670c455b8d948aff95ed50e22940d1ad3fc
- https://github.com/jpadilla/pyjwt/releases/tag/2.4.0
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6HIYEYZRQEP6QTHT3EHH3RGFYJIHIMAO/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5PK7IQCBVNLYJEFTPHBBPFP72H4WUFNX/
- https://www.vicarius.io/vsociety/posts/risky-algorithms-algorithm-confusion-in-pyjwt-cve-2022-29217
- https://nvd.nist.gov/vuln/detail/CVE-2022-29217