GHSA-63cx-g855-hvv4
GHSA-63cx-g855-hvv4 · mitmproxy binaries embed a vulnerable python-hyper/h2 dependency
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
mitmproxy 12.1.1 and below embed python-hyper/h2 ≤ v4.2.0, which has a gap in its HTTP/2 header validation. This enables request smuggling attacks when mitmproxy is in a configuration where it translates HTTP/2 to HTTP/1. For example, this affects reverse proxies to `http://` backends. It does not affect mitmproxy's regular mode. All users are encouraged to upgrade to mitmproxy 12.1.2, which includes a fixed version of h2. More details about the vulnerability itself can be found at https://github.com/python-hyper/h2/security/advisories/GHSA-847f-9342-265h.
CVSS 6.9 · Media · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
mitmproxy PyPI
- Versiones
- 0.10
- 0.10.1
- 0.11
- 0.11.1
- 0.11.2
- 0.11.3
- 0.12.0
- 0.12.1
- 0.13
- 0.14.0
- 0.15
- 0.16
- 0.17
- 0.18.1
- 0.18.2
- 0.18.3
- 0.8
- 0.8.1
- 0.9
- 0.9.1
- 0.9.2
- 1.0.0
- 1.0.1
- 1.0.2
- 10.0.0
- 10.1.0
- 10.1.1
- 10.1.2
- 10.1.3
- 10.1.4
- 10.1.5
- 10.1.6
- 10.2.0
- 10.2.1
- 10.2.2
- 10.2.3
- 10.2.4
- 10.3.0
- 10.3.1
- 10.4.0
- 10.4.1
- 10.4.2
- 11.0.0
- 11.0.1
- 11.0.2
- 11.1.0
- 11.1.2
- 11.1.3
- 12.0.0
- 12.0.1
- 12.1.0
- 12.1.1
- 2.0.0
- 2.0.1
- 2.0.2
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- 4.0.0
- 4.0.1
- 4.0.3
- 4.0.4
- 5.0.0
- 5.0.1
- 5.1.0
- 5.1.1
- 5.2
- 5.3.0
- 6.0.0
- 6.0.1
- 6.0.2
- 7.0.0
- 7.0.1
- 7.0.2
- 7.0.3
- 7.0.4
- 8.0.0
- 8.1.0
- 8.1.1
- 9.0.0
- 9.0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 12.1.2
Actualiza a 12.1.2