p PatchFirst

GHSA-65v7-wg35-2qpm

GHSA-65v7-wg35-2qpm · Sylius Resource Bundle Cross-Site Request Forgery vulnerability

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Sylius 1.0.0 to 1.0.16, 1.1.0 to 1.1.8, 1.2.0 to 1.2.1 versions of AdminBundle and ResourceBundle are affected by this security issue. This issue has been fixed in Sylius 1.0.17, 1.1.9 and 1.2.2. Development branch for 1.3 release has also been fixed. ### Description The following actions in the admin panel did not require a CSRF token: - marking order’s payment as completed - marking order’s payment as refunded - marking product review as accepted - marking product review as rejected ### Resolution The issue is fixed by adding a required CSRF token to those actions. We also fixed `ResourceController`‘s `applyStateMachineTransitionAction` method by adding a CSRF token check. If you use that action in the API context, you can disable it by adding `csrf_protection:` false to its routing configuration

CVSS 6.5 · Media · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • sylius/resource-bundle Packagist

    Versiones
    • v1.0.0
    • v1.0.1
    • v1.0.10
    • v1.0.11
    • v1.0.12
    • v1.0.13
    • v1.0.14
    • v1.0.15
    • v1.0.16
    • v1.0.2
    • v1.0.3
    • v1.0.4
    • v1.0.5
    • v1.0.6
    • v1.0.7
    • v1.0.8
    • v1.0.9
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.0, < 1.0.17

    Actualiza a 1.0.17

  • sylius/resource-bundle Packagist

    Versiones
    • v1.1.0
    • v1.1.1
    • v1.1.2
    • v1.1.3
    • v1.1.4
    • v1.1.5
    • v1.1.6
    • v1.1.7
    • v1.1.8
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.1.0, < 1.1.9

    Actualiza a 1.1.9

  • sylius/resource-bundle Packagist

    Versiones
    • v1.2.0
    • v1.2.1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.2.0, < 1.2.2

    Actualiza a 1.2.2

Fuentes originales

Comprueba tu servidor →