p PatchFirst

GHSA-fh7v-q458-7vmw

GHSA-fh7v-q458-7vmw · ibexa/http-cache affected by Breach with Varnish VCL

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

### Impact This is not a vulnerability in the code per se, but included Varnish VCL templates enable compression of API and JSON messages. This is a potential case of the BREACH vulnerability, which affects HTTP compression, where secrets can be extracted through carefully crafted requests. The fix disables compression in these templates. Please make sure to make the same change in your configuration files, see the release notes for specific instructions. Please check your web server configuration as well. ### Patches - See "Patched versions". - https://github.com/ibexa/http-cache/commit/e03f683e8db53b6d253e1af8177befeecc8d3914 ### Workarounds Make sure HTTP compression is disabled for REST API requests and other communication that might contain secrets. ### References - Advisory: https://developers.ibexa.co/security-advisories/ibexa-sa-2024-006-vulnerabilities-in-content-name-pattern-commerce-shop-and-varnish-vhost-templates - Release notes: https://doc.ibexa.co/en/latest/update_and_migration/from_4.6/update_from_4.6/#v4614 - https://github.com/ibexa/post-install/security/advisories/GHSA-4h8f-c635-25p7 - https://github.com/ezsystems/ezplatform-http-cache/security/advisories/GHSA-mgfg-7533-7jf6 - https://www.breachattack.com/

Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • ibexa/http-cache Packagist

    Versiones
    • v4.6.0
    • v4.6.1
    • v4.6.10
    • v4.6.11
    • v4.6.12
    • v4.6.13
    • v4.6.2
    • v4.6.3
    • v4.6.4
    • v4.6.5
    • v4.6.6
    • v4.6.7
    • v4.6.8
    • v4.6.9
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 4.6.0, < 4.6.14

    Actualiza a 4.6.14

Fuentes originales

Comprueba tu servidor →