p PatchFirst

GHSA-mqf5-275h-gf6r

GHSA-mqf5-275h-gf6r · Silverstripe framework is vulnerable to XSS in install.php

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

During installation, certain parameters (admin_username and admin_password) are not escaped in the setup form. This issue is resolved in 3.1.14 stable, although existing users are advised to remove this file prior to deploying to a production server.

CVSS 6.1 · Media · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • silverstripe/framework Packagist

    Versiones
    • 3.1.0
    • 3.1.1
    • 3.1.10
    • 3.1.10-rc1
    • 3.1.10-rc2
    • 3.1.11
    • 3.1.11-rc1
    • 3.1.12
    • 3.1.13
    • 3.1.13-rc1
    • 3.1.14-rc1
    • 3.1.2
    • 3.1.2-rc1
    • 3.1.3
    • 3.1.3-rc1
    • 3.1.3-rc2
    • 3.1.4
    • 3.1.4-rc1
    • 3.1.5
    • 3.1.5-rc1
    • 3.1.6
    • 3.1.6-rc1
    • 3.1.6-rc2
    • 3.1.6-rc3
    • 3.1.7
    • 3.1.7-rc1
    • 3.1.8
    • 3.1.9
    • 3.1.9-rc1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 3.1.0, < 3.1.14

    Actualiza a 3.1.14

Fuentes originales

Comprueba tu servidor →