p PatchFirst

GHSA-p72q-h37j-3hq7

GHSA-p72q-h37j-3hq7 · dbt uses a SQLparse version with a high vulnerability

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

### Summary Using a version of `sqlparse` that has a security vulnerability and no way to update in current version of dbt core. Snyk recommends using `sqlparse==0.5` but this causes a conflict with dbt. Snyk states the issues is a recursion error: `SNYK-PYTHON-SQLPARSE-6615674`. ### Details Dependency conflict error message: ```sh The conflict is caused by: The user requested sqlparse==0.5 dbt-core 1.7.10 depends on sqlparse<0.5 and >=0.2.3 ``` Resolution was to pin `sqlparse >=0.5.0, <0.6.0` in `dbt-core`, patched in 1.6.13 and 1.7.13. ### PoC From Snyk: ```python import sqlparse sqlparse.parse('[' * 10000 + ']' * 10000) ``` ### Impact Snyk classifies it as high 7.5/10. ### Patches The bug has been fixed in [dbt-core v1.6.13](https://github.com/dbt-labs/dbt-core/releases/tag/v1.6.13) and [dbt-core v1.7.13](https://github.com/dbt-labs/dbt-core/releases/tag/v1.7.13). ### Mitigations Bump `dbt-core` 1.6 and 1.7 dependencies to 1.6.13 and 1.7.13 respectively

CVSS 7.5 · Alta · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • dbt-core PyPI

    Versiones
    • 1.6.0
    • 1.6.1
    • 1.6.10
    • 1.6.11
    • 1.6.12
    • 1.6.1rc1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    • 1.6.6
    • 1.6.7
    • 1.6.8
    • 1.6.9
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.6.0, < 1.6.13

    Actualiza a 1.6.13

  • dbt-core PyPI

    Versiones
    • 1.7.0
    • 1.7.1
    • 1.7.10
    • 1.7.11
    • 1.7.12
    • 1.7.2
    • 1.7.3
    • 1.7.4
    • 1.7.5
    • 1.7.6
    • 1.7.7
    • 1.7.8
    • 1.7.9
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.7.0, < 1.7.13

    Actualiza a 1.7.13

Fuentes originales

Comprueba tu servidor →