GHSA-wjfc-pgfp-pv9c
GHSA-wjfc-pgfp-pv9c · Improper Input Validation in nyholm/psr7
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
### Impact Improper header parsing. An attacker could sneak in a newline (`\n`) into both the header names and values. While the specification states that `\r\n\r\n` is used to terminate the header list, many servers in the wild will also accept `\n\n`. ### Patches The issue is patched in 1.6.1. ### Workarounds There are no known workarounds. ### References * https://www.rfc-editor.org/rfc/rfc7230#section-3.2.4
CVSS 5.3 · Media · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
nyholm/psr7 Packagist
- Versiones
- 0.1.0
- 0.2.0
- 0.2.1
- 0.2.2
- 0.2.3
- 0.3.0
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.1
Actualiza a 1.6.1
Fuentes originales
- https://github.com/Nyholm/psr7/security/advisories/GHSA-wjfc-pgfp-pv9c
- https://github.com/guzzle/psr7/security/advisories/GHSA-q7rv-6hp3-vh96
- https://github.com/guzzle/psr7/security/advisories/GHSA-wxmh-65f7-jcvw
- https://nvd.nist.gov/vuln/detail/CVE-2023-29197
- https://github.com/FriendsOfPHP/security-advisories/blob/master/nyholm/psr7/2023-04-17.yaml
- https://github.com/Nyholm/psr7
- https://osv.dev/vulnerability/GHSA-wjfc-pgfp-pv9c