p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de @apollo/gateway

Vulnerabilidades publicadas para @apollo/gateway en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 5

  1. CVE-2026-32621

    Crítica · CVSS 9.9EPSS 0,54%Corrección disponible

    Apollo Federation has prototype pollution via incomplete key sanitization

    Apollo Federation is an architecture for declaratively composing APIs into a unified graph. Prior to 2.9.6, 2.10.5, 2.11.6, 2.12.3, and 2.13.2, a vulnerability exists in query plan execution within the gateway that may allow pollution of Object.prototype in certain scenarios. A malicious client may be able to pollute Object.prototype in gateway directly by crafting operations with field aliases and/or variable names that target prototype-inheritable properties. Alternatively, if a subgraph were to be compromised by a malicious actor, they may be able to pollute Object.prototype in gateway by crafting JSON response payloads that target prototy

    • Actualiza a 2.10.5
    • Actualiza a 2.11.6
    • Actualiza a 2.12.3
    • Actualiza a 2.13.2
    • Actualiza a 2.9.6
    Publicación Actualización
  2. CVE-2025-32031

    Alta · CVSS 7.5EPSS 0,6%Corrección disponible

    Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Optimization Bypass

    Apollo Gateway provides utilities for combining multiple GraphQL microservices into a single GraphQL endpoint. Prior to 2.10.1, a vulnerability in Apollo Gateway allowed queries with deeply nested and reused named fragments to be prohibitively expensive to query plan, specifically due to internal optimizations being frequently bypassed. The query planner includes an optimization that significantly speeds up planning for applicable GraphQL selections. However, queries with deeply nested and reused named fragments can generate many selections where this optimization does not apply, leading to significantly longer planning times. Because the que

    • Actualiza a 2.10.1
    Publicación Actualización
  3. CVE-2025-32030

    Alta · CVSS 7.5EPSS 0,53%Corrección disponible

    Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Named Fragment Expansion

    Apollo Gateway provides utilities for combining multiple GraphQL microservices into a single GraphQL endpoint. Prior to 2.10.1, a vulnerability in Apollo Gateway allowed queries with deeply nested and reused named fragments to be prohibitively expensive to query plan, specifically during named fragment expansion. Named fragments were being expanded once per fragment spread during query planning, leading to exponential resource usage when deeply nested and reused fragments were involved. This could lead to excessive resource consumption and denial of service. This has been remediated in @apollo/gateway version 2.10.1.

    • Actualiza a 2.10.1
    Publicación Actualización
  4. CVE-2024-43414

    Alta · CVSS 7.5EPSS 0,99%Corrección disponible

    Apollo Query Planner and Apollo Gateway may infinitely loop on sufficiently complex queries

    Apollo Federation is an architecture for declaratively composing APIs into a unified graph. Each team can own their slice of the graph independently, empowering them to deliver autonomously and incrementally. Instances of @apollo/query-planner >=2.0.0 and <2.8.5 are impacted by a denial-of-service vulnerability. @apollo/gateway versions >=2.0.0 and < 2.8.5 and Apollo Router <1.52.1 are also impacted through their use of @apollo/query-panner. If @apollo/query-planner is asked to plan a sufficiently complex query, it may loop infinitely and never complete. This results in unbounded memory consumption and either a crash or out-of-memory (OOM) te

    • Actualiza a 2.8.5
    Publicación Actualización
  5. GHSA-74cr-77xc-8g6r

    Alta · CVSS 7.3Corrección disponible

    Prototype Pollution in @apollo/gateway

    Versions of `@apollo/gateway` prior to 0.6.2 are vulnerable to Prototype Pollution. The package uses deepMerge() to merge objects, which may allow attackers to alter the Object prototype through queries with GraphQL aliases. Carefully constructed payloads can override properties of all objects in the application. This may lead to Denial of Service or may be chained with other vulnerabilities leading to Remote Code Execution. ## Recommendation Upgrade to version 0.6.2 or later.

    • Actualiza a 0.6.2
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →