p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de @keystone-6/core

Vulnerabilidades publicadas para @keystone-6/core en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 8

  1. CVE-2026-63421

    Alta · CVSS 7.5EPSS 0,67%Corrección disponible

    Keystone: `graphql.maxTake` bypass with negative `take`

    Keystone is a content management system for Node.js. Prior to 6.5.3, the findMany resolver in packages/core/src/lib/core/queries/resolvers.ts compares the signed take argument directly with graphql.maxTake, allowing a remote unauthenticated GraphQL client to provide a negative take value whose magnitude exceeds the configured bound. The bypass also applies to relationship queries and can return more records than the developer intended, potentially exhausting service resources. This issue is fixed in version 6.5.3.

    • Actualiza a 6.5.3
    Publicación Actualización
  2. CVE-2026-10802

    Media · CVSS 5.3EPSS 0,31%Sin corrección publicada

    keystonejs keystone GraphQL API Endpoint output-field.ts resource consumption

    A vulnerability was detected in keystonejs keystone up to 20260319. This vulnerability affects unknown code in the library packages/core/src/lib/core/queries/output-field.ts of the component GraphQL API Endpoint. The manipulation results in resource consumption. It is possible to launch the attack remotely. The exploit is now public and may be used. The pull request to fix this issue awaits acceptance.

    Publicación Actualización
  3. CVE-2026-33326

    Media · CVSS 4.3EPSS 0,27%Corrección disponible

    @keystone-6/core: `isFilterable` bypass via `cursor` parameter in findMany

    Keystone is a content management system for Node.js. Prior to version 6.5.2, {field}.isFilterable access control can be bypassed in findMany queries by passing a cursor. This can be used to confirm the existence of records by protected field values. The fix for CVE-2025-46720 (field-level isFilterable bypass for update and delete mutations) added checks to the where parameter in update and delete mutations however the cursor parameter in findMany was not patched and accepts the same UniqueWhere input type. This issue has been patched in version 6.5.2.

    • Actualiza a 6.5.2
    Publicación Actualización
  4. CVE-2025-46720

    Baja · CVSS 3.1EPSS 0,28%Corrección disponible

    Keystone has an unintended `isFilterable` bypass that can be used as an oracle to match hidden fields

    Keystone is a content management system for Node.js. Prior to version 6.5.0, `{field}.isFilterable` access control can be bypassed in `update` and `delete` mutations by adding additional unique filters. These filters can be used as an oracle to probe the existence or value of otherwise unreadable fields. Specifically, when a mutation includes a `where` clause with multiple unique filters (e.g. `id` and `email`), Keystone will attempt to match records even if filtering by the latter fields would normally be rejected by `field.isFilterable` or `list.defaultIsFilterable`. This can allow malicious actors to infer the presence of a particular fiel

    • Actualiza a 6.5.0
    Publicación Actualización
  5. CVE-2023-40027

    Baja · CVSS 3.7EPSS 0,58%Corrección disponible

    Conditionally missing authorization in @keystone-6/core

    Keystone is an open source headless CMS for Node.js — built with GraphQL and React. When `ui.isAccessAllowed` is set as `undefined`, the `adminMeta` GraphQL query is publicly accessible (no session required). This is different to the behaviour of the default AdminUI middleware, which by default will only be publicly accessible (no session required) if a `session` strategy is not defined. This vulnerability does not affect developers using the `@keystone-6/auth` package, or any users that have written their own `ui.isAccessAllowed` (that is to say, `isAccessAllowed` is not `undefined`). This vulnerability does affect users who believed that th

    • Actualiza a 5.5.1
    Publicación Actualización
  6. GHSA-5fp6-4xw3-xqq3

    Sin evaluarSin corrección publicada

    @keystone-6/core's bundled cuid package known to be insecure

    ### Summary The `cuid` package used by `@keystone-6/*` and upstream dependencies is deprecated and [marked as insecure by the author](https://github.com/paralleldrive/cuid#status-deprecated-due-to-security-use-cuid2-instead). As reported by the author > Cuid and other k-sortable and non-cryptographic ids (Ulid, ObjectId, KSUID, all UUIDs) are all insecure. Use @paralleldrive/cuid2 instead. ### What are doing about this? - [We are waiting on Prisma](https://github.com/keystonejs/keystone/issues/8282) to add support for [`cuid2`](https://github.com/paralleldrive/cuid2) - Alternatively, we might default to a random string ourselves ### What c

    Publicación Actualización
  7. CVE-2022-39382

    Crítica · CVSS 9.8EPSS 1,65%Corrección disponible

    NODE_ENV in Keystone defaults to development with esbuild

    Keystone is a headless CMS for Node.js — built with GraphQL and React.`@keystone-6/[email protected] || 3.0.1` users that use `NODE_ENV` to trigger security-sensitive functionality in their production builds are vulnerable to `NODE_ENV` being inlined to `"development"` for user code, irrespective of what your environment variables. If you do not use `NODE_ENV` in your user code to trigger security-sensitive functionality, you are not impacted by this vulnerability. Any dependencies that use `NODE_ENV` to trigger particular behaviors (optimizations, security or otherwise) should still respect your environment's configured `NODE_ENV` variable. The app

    • Actualiza a 3.0.2
    Publicación Actualización
  8. CVE-2022-39322

    Crítica · CVSS 9.1EPSS 1,46%Corrección disponible

    @keystone-6/core vulnerable to field-level access-control bypass for multiselect field

    @keystone-6/core is a core package for Keystone 6, a content management system for Node.js. Starting with version 2.2.0 and prior to version 2.3.1, users who expected their `multiselect` fields to use the field-level access control - if configured - are vulnerable to their field-level access control not being used. List-level access control is not affected. Field-level access control for fields other than `multiselect` are not affected. Version 2.3.1 contains a fix for this issue. As a workaround, stop using the `multiselect` field.

    • Actualiza a 2.3.1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →