p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de nodebb

Vulnerabilidades publicadas para nodebb en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 14

  1. CVE-2025-50979

    Alta · CVSS 8.6EPSS 10,61%Sin corrección publicada

    CVE-2025-50979

    NodeBB v4.3.0 is vulnerable to SQL injection in its search-categories API endpoint (/api/v3/search/categories). The search query parameter is not properly sanitized, allowing unauthenticated, remote attackers to inject boolean-based blind and PostgreSQL error-based payloads.

    Publicación Actualización
  2. CVE-2023-2850

    Media · CVSS 4.7EPSS 0,33%Corrección disponible

    CVE-2023-2850

    NodeBB is affected by a Cross-Site WebSocket Hijacking vulnerability due to missing validation of the request origin. Exploitation of this vulnerability allows certain user information to be extracted by attacker.

    • Actualiza a 2.8.13
    • Actualiza a 3.1.3
    Publicación Actualización
  3. CVE-2023-26045

    Crítica · CVSS 10EPSS 1,03%Corrección disponible

    NodeBB vulnerable to path traversal and code execution via prototype vulnerability

    NodeBB is Node.js based forum software. Starting in version 2.5.0 and prior to version 2.8.7, due to the use of the object destructuring assignment syntax in the user export code path, combined with a path traversal vulnerability, a specially crafted payload could invoke the user export logic to arbitrarily execute javascript files on the local disk. This issue is patched in version 2.8.7. As a workaround, site maintainers can cherry pick the fix into their codebase to patch the exploit.

    • Actualiza a 2.8.7
    Publicación Actualización
  4. CVE-2022-46164

    Crítica · CVSS 9.4EPSS 47,37%Corrección disponible

    Account takeover via prototype vulnerability

    NodeBB is an open source Node.js based forum software. Due to a plain object with a prototype being used in socket.io message handling a specially crafted payload can be used to impersonate other users and takeover accounts. This vulnerability has been patched in version 2.6.1. Users are advised to upgrade. Users unable to upgrade may cherry-pick commit `48d143921753914da45926cca6370a92ed0c46b8` into their codebase to patch the exploit.

    • Actualiza a 2.6.1
    Publicación Actualización
  5. CVE-2022-3978

    Media · CVSS 4.3EPSS 0,38%Corrección disponible

    NodeBB abort cross-site request forgery

    A vulnerability, which was classified as problematic, was found in NodeBB up to 2.5.7. This affects an unknown part of the file /register/abort. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 2.5.8 is able to address this issue. The name of the patch is 2f9d8c350e54543f608d3d4c8e1a49bbb6cdea38. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-213555.

    • Actualiza a 2.5.8
    Publicación Actualización
  6. CVE-2022-36076

    Alta · CVSS 8.8EPSS 0,58%Corrección disponible

    Account takeover via SSO plugins in NodeBB

    NodeBB Forum Software is powered by Node.js and supports either Redis, MongoDB, or a PostgreSQL database. Due to an unnecessarily strict conditional in the code handling the first step of the SSO process, the pre-existing logic that added (and later checked) a nonce was inadvertently rendered opt-in instead of opt-out. This re-exposed a vulnerability in that a specially crafted Man-in-the-Middle (MITM) attack could theoretically take over another user account during the single sign-on process. The issue has been fully patched in version 1.17.2.

    • Actualiza a 1.17.2
    Publicación Actualización
  7. CVE-2022-36045

    Crítica · CVSS 9EPSS 1,35%Corrección disponible

    Account takeover via cryptographically weak PRNG in NodeBB Forum

    NodeBB Forum Software is powered by Node.js and supports either Redis, MongoDB, or a PostgreSQL database. It utilizes web sockets for instant interactions and real-time notifications. `utils.generateUUID`, a helper function available in essentially all versions of NodeBB (as far back as v1.0.1 and potentially earlier) used a cryptographically insecure Pseudo-random number generator (`Math.random()`), which meant that a specially crafted script combined with multiple invocations of the password reset functionality could enable an attacker to correctly calculate the reset code for an account they do not have access to. This vulnerability impact

    • Actualiza a 1.19.8
    • Actualiza a 2.0.1
    Publicación Actualización
  8. CVE-2021-43788

    Media · CVSS 5EPSS 25,84%Corrección disponible

    Path traversal in translator module of NobeBB

    Nodebb is an open source Node.js based forum software. Prior to v1.18.5, a path traversal vulnerability was present that allowed users to access JSON files outside of the expected `languages/` directory. The vulnerability has been patched as of v1.18.5. Users are advised to upgrade as soon as possible.

    • Actualiza a 1.18.5
    Publicación Actualización
  9. CVE-2021-43786

    Crítica · CVSS 9.8EPSS 2,37%Corrección disponible

    API token verification can be bypassed

    Nodebb is an open source Node.js based forum software. In affected versions incorrect logic present in the token verification step unintentionally allowed master token access to the API. The vulnerability has been patch as of v1.18.5. Users are advised to upgrade as soon as possible.

    • Actualiza a 1.18.5
    Publicación Actualización
  10. CVE-2021-43787

    Crítica · CVSS 9EPSS 1,32%Corrección disponible

    XSS via prototype pollution

    Nodebb is an open source Node.js based forum software. In affected versions a prototype pollution vulnerability in the uploader module allowed a malicious user to inject arbitrary data (i.e. javascript) into the DOM, theoretically allowing for an account takeover when used in conjunction with a path traversal vulnerability disclosed at the same time as this report. The vulnerability has been patched as of v1.18.5. Users are advised to upgrade as soon as possible.

    • Actualiza a 1.18.5
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →