p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de showdown

Vulnerabilidades publicadas para showdown en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 4

  1. CVE-2026-59710

    Media · CVSS 5.3EPSS 0,34%Sin corrección publicada

    showdown - Stored XSS via Unescaped Table Header ID Attribute Injection

    showdown contains a stored cross-site scripting vulnerability in the parseHeaders function of src/subParsers/makehtml/tables.js that fails to properly escape table header ID attributes. Attackers can inject arbitrary HTML and script-executing SVG elements through double-quote characters in markdown table headers, achieving stored XSS when untrusted markdown is rendered with the default github flavor configuration.

    Publicación Actualización
  2. CVE-2026-59711

    Media · CVSS 5.3EPSS 0,23%Sin corrección publicada

    showdown - Cross-Site Scripting via Unescaped Metadata Title in completeHTMLDocument

    showdown contains a cross-site scripting vulnerability in metadata title handling that allows attackers to inject arbitrary HTML and JavaScript. When completeHTMLDocument option is enabled, unescaped less-than and greater-than characters in markdown frontmatter metadata are inserted directly into HTML title tags, enabling attackers to break out of the title context and execute malicious scripts in the rendered page.

    Publicación Actualización
  3. CVE-2024-1899

    Media · CVSS 5.3EPSS 0,81%Sin corrección publicada

    Showdownjs Denial of Service

    An issue in the anchors subparser of Showdownjs versions <= 2.1.0 could allow a remote attacker to cause denial of service conditions.

    Publicación Actualización
  4. GHSA-h6mq-3cj6-h738

    Baja · CVSS 3.1Corrección disponible

    Reverse Tabnabbing in showdown

    Versions of `showdown` prior to 1.9.1 are vulnerable to [Reverse Tabnabbing](https://www.owasp.org/index.php/Reverse_Tabnabbing). The package uses `target='_blank'` in anchor tags, allowing attackers to access `window.opener` for the original page when opening links. This is commonly used for phishing attacks. ## Recommendation Upgrade to version 1.9.1 or later.

    • Actualiza a 1.9.1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →