p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de flarum/framework

Vulnerabilidades publicadas para flarum/framework en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 4

  1. CVE-2025-27794

    Media · CVSS 6.8EPSS 0,5%Corrección disponible

    Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite

    Flarum is open-source forum software. A session hijacking vulnerability exists in versions prior to 1.8.10 when an attacker-controlled authoritative subdomain under a parent domain (e.g., `subdomain.host.com`) sets cookies scoped to the parent domain (`.host.com`). This allows session token replacement for applications hosted on sibling subdomains (e.g., `community.host.com`) if session tokens aren't rotated post-authentication. Key Constraints are that the attacker must control any subdomain under the parent domain (e.g., `evil.host.com` or `x.y.host.com`), and the parent domain must not be on the Public Suffix List. Due to non-existent sess

    • Actualiza a 1.8.10
    Publicación Actualización
  2. CVE-2024-21641

    Media · CVSS 6.5EPSS 1,07%Código de explotación públicoCorrección disponible

    Flarum's Logout Route allows open redirects

    Flarum is open source discussion platform software. Prior to version 1.8.5, the Flarum `/logout` route includes a redirect parameter that allows any third party to redirect users from a (trusted) domain of the Flarum installation to redirect to any link. For logged-in users, the logout must be confirmed. Guests are immediately redirected. This could be used by spammers to redirect to a web address using a trusted domain of a running Flarum installation. The vulnerability has been fixed and published as flarum/core v1.8.5. As a workaround, some extensions modifying the logout route can remedy this issue if their implementation is safe.

    • Actualiza a 1.8.5
    Publicación Actualización
  3. CVE-2023-40033

    Alta · CVSS 7.1EPSS 0,5%Corrección disponible

    Server-Side Request Forgery via Avatar upload in flarum

    Flarum is an open source forum software. Flarum is affected by a vulnerability that allows an attacker to conduct a Blind Server-Side Request Forgery (SSRF) attack or disclose any file on the server, even with a basic user account on any Flarum forum. By uploading a file containing a URL and spoofing the MIME type, an attacker can manipulate the application to execute unintended actions. The vulnerability is due to the behavior of the `intervention/image` package, which attempts to interpret the supplied file contents as a URL, which then fetches its contents. This allows an attacker to exploit the vulnerability to perform SSRF attacks, discl

    • Actualiza a 1.8.0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →