p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de apache-airflow · Página 8

Vulnerabilidades publicadas para apache-airflow en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 158

  1. CVE-2020-17515

    Media · CVSS 6.1EPSS 16,21%Corrección disponible

    CVE-2020-17515

    The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit. This issue affects Apache Airflow versions prior to 1.10.13. This is same as CVE-2020-13944 but the implemented fix in Airflow 1.10.13 did not fix the issue completely.

    • Actualiza a 1.10.13
    • Actualiza a 1.10.15rc1
    • Actualiza a 2.0.2rc1
    Publicación Actualización
  2. CVE-2020-13927

    Crítica · CVSS 9.8EPSS 99,78%En el catálogo KEVCódigo de explotación públicoCorrección disponible

    CVE-2020-13927

    The previous default setting for Airflow's Experimental API was to allow all API requests without authentication, but this poses security risks to users who miss this fact. From Airflow 1.10.11 the default has been changed to deny all requests by default and is documented at https://airflow.apache.org/docs/1.10.11/security.html#api-authentication. Note this change fixes it for new installs but existing users need to change their config to default `[api]auth_backend = airflow.api.auth.backend.deny_all` as mentioned in the Updating Guide: https://github.com/apache/airflow/blob/1.10.11/UPDATING.md#experimental-api-will-deny-all-request-by-defaul

    • Actualiza a 1.10.11
    Publicación Actualización
  3. CVE-2020-11983

    Media · CVSS 5.4EPSS 1,77%Corrección disponible

    CVE-2020-11983

    An issue was found in Apache Airflow versions 1.10.10 and below. It was discovered that many of the admin management screens in the new/RBAC UI handled escaping incorrectly, allowing authenticated users with appropriate permissions to create stored XSS attacks.

    • Actualiza a 1.10.11
    • Actualiza a 1.10.11rc1
    Publicación Actualización
  4. CVE-2020-11982

    Crítica · CVSS 9.8EPSS 7,22%Corrección disponible

    CVE-2020-11982

    An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attack can connect to the broker (Redis, RabbitMQ) directly, it was possible to insert a malicious payload directly to the broker which could lead to a deserialization attack (and thus remote code execution) on the Worker.

    • Actualiza a 1.10.11
    • Actualiza a 1.10.11rc1
    Publicación Actualización
  5. CVE-2020-11981

    Crítica · CVSS 9.8EPSS 36,79%Código de explotación públicoCorrección disponible

    CVE-2020-11981

    An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attacker can connect to the broker (Redis, RabbitMQ) directly, it is possible to inject commands, resulting in the celery worker running arbitrary commands.

    • Actualiza a 1.10.11rc1
    Publicación Actualización
  6. CVE-2020-11978

    Alta · CVSS 8.8EPSS 99,19%En el catálogo KEVCódigo de explotación públicoCorrección disponible

    CVE-2020-11978

    An issue was found in Apache Airflow versions 1.10.10 and below. A remote code/command injection vulnerability was discovered in one of the example DAGs shipped with Airflow which would allow any authenticated user to run arbitrary commands as the user running airflow worker/scheduler (depending on the executor in use). If you already have examples disabled by setting load_examples=False in the config then you are not vulnerable.

    • Actualiza a 1.10.11rc1
    Publicación Actualización
  7. CVE-2019-12417

    Media · CVSS 4.8EPSS 1,28%Corrección disponible

    CVE-2019-12417

    A malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views. This also presented a Local File Disclosure vulnerability to any file readable by the webserver process.

    • Actualiza a 1.10.6rc1
    Publicación Actualización
  8. CVE-2018-20245

    Alta · CVSS 8.7EPSS 1,02%Corrección disponible

    CVE-2018-20245

    The LDAP auth backend (airflow.contrib.auth.backends.ldap_auth) prior to Apache Airflow 1.10.1 was misconfigured and contained improper checking of exceptions which disabled server certificate checking.

    • Actualiza a 1.10.1
    Publicación Actualización
  9. CVE-2017-17836

    Crítica · CVSS 9.8EPSS 3,19%Corrección disponible

    CVE-2017-17836

    In Apache Airflow 1.8.2 and earlier, an experimental Airflow feature displayed authenticated cookies, as well as passwords to databases used by Airflow. An attacker who has limited access to airflow, whether it be via XSS or by leaving a machine unlocked can exfiltrate all credentials from the system.

    • Actualiza a 1.9.0
    Publicación Actualización
  10. CVE-2017-12614

    Media · CVSS 6.1EPSS 2,02%Corrección disponible

    CVE-2017-12614

    It was noticed an XSS in certain 404 pages that could be exploited to perform an XSS attack. Chrome will detect this as a reflected XSS attempt and prevent the page from loading. Firefox and other browsers don't, and are vulnerable to this attack. Mitigation: The fix for this is to upgrade to Apache Airflow 1.9.0 or above.

    • Actualiza a 1.9.0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →