p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de fastapi-guard

Vulnerabilidades publicadas para fastapi-guard en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 3

  1. CVE-2025-54365

    Alta · CVSS 7.8EPSS 0,87%Corrección disponible

    fastapi-guard patch contains bypassable RegEx

    fastapi-guard is a security library for FastAPI that provides middleware to control IPs, log requests, detect penetration attempts and more. In version 3.0.1, the regular expression patched to mitigate the ReDoS vulnerability by limiting the length of string fails to catch inputs that exceed this limit. This type of patch fails to detect cases in which the string representing the attributes of a <script> tag exceeds 100 characters. As a result, most of the regex patterns present in version 3.0.1 can be bypassed. This is fixed in version 3.0.2.

    • Actualiza a 3.0.2
    Publicación Actualización
  2. CVE-2025-53539

    Media · CVSS 6.9EPSS 0,48%Corrección disponible

    ReDoS in fastapi-guard's penetration attempts detector

    FastAPI Guard is a security library for FastAPI that provides middleware to control IPs, log requests, and detect penetration attempts. fastapi-guard's penetration attempts detection uses regex to scan incoming requests. However, some of the regex patterns used in detection are extremely inefficient and can cause polynomial complexity backtracks when handling specially crafted inputs. This vulnerability is fixed in 3.0.1.

    • Actualiza a 3.0.1
    Publicación Actualización
  3. CVE-2025-46814

    Baja · CVSS 3.4EPSS 0,34%Corrección disponible

    FastAPI Guard Remote Header Injection via X-Forwarded-For Manipulation

    FastAPI Guard is a security library for FastAPI that provides middleware to control IPs, log requests, and detect penetration attempts. An HTTP header injection vulnerability has been identified in versions prior to 2.0.0. By manipulating the X-Forwarded-For header, an attacker can potentially inject arbitrary IP addresses into the request. This vulnerability can allow attackers to bypass IP-based access controls, mislead logging systems, and impersonate trusted clients. It is especially impactful when the application relies on the X-Forwarded-For header for IP-based authorization or authentication. Users should upgrade to FastAPI Guard versi

    • Actualiza a 2.0.0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →