p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de invokeai

Vulnerabilidades publicadas para invokeai en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 5

  1. CVE-2025-6237

    Crítica · CVSS 9.8EPSS 0,4%Corrección disponible

    Path Traversal and Arbitrary File Deletion in invoke-ai/invokeai

    A vulnerability in invokeai version v6.0.0a1 and below allows attackers to perform path traversal and arbitrary file deletion via the GET /api/v1/images/download/{bulk_download_item_name} endpoint. By manipulating the filename arguments, attackers can read and delete any files on the server, including critical system files such as SSH keys, databases, and configuration files. This vulnerability results in high confidentiality, integrity, and availability impacts.

    • Actualiza a 6.7.0
    Publicación Actualización
  2. CVE-2024-11043

    Alta · CVSS 7.5EPSS 0,72%Sin corrección publicada

    Denial of Service (DoS) via Large Payload in Board Name Field in invoke-ai/invokeai

    A Denial of Service (DoS) vulnerability was discovered in the /api/v1/boards/{board_id} endpoint of invoke-ai/invokeai version v5.0.2. This vulnerability occurs when an excessively large payload is sent in the board_name field during a PATCH request. By sending a large payload, the UI becomes unresponsive, rendering it impossible for users to interact with or manage the affected board. Additionally, the option to delete the board becomes inaccessible, amplifying the severity of the issue.

    Publicación Actualización
  3. CVE-2024-10821

    Alta · CVSS 7.5EPSS 0,64%Sin corrección publicada

    Denial of Service (DoS) in invoke-ai/invokeai

    A Denial of Service (DoS) vulnerability in the multipart request boundary processing mechanism of the Invoke-AI server (version v5.0.1) allows unauthenticated attackers to cause excessive resource consumption. The server fails to handle excessive characters appended to the end of multipart boundaries, leading to an infinite loop and a complete denial of service for all users. The affected endpoint is `/api/v1/images/upload`.

    Publicación Actualización
  4. CVE-2024-11042

    Crítica · CVSS 9.1EPSS 1,56%Corrección disponible

    Arbitrary File Delete in invoke-ai/invokeai

    In invoke-ai/invokeai version v5.0.2, the web API `POST /api/v1/images/delete` is vulnerable to Arbitrary File Deletion. This vulnerability allows unauthorized attackers to delete arbitrary files on the server, potentially including critical or sensitive system files such as SSH keys, SQLite databases, and configuration files. This can impact the integrity and availability of applications relying on these files.

    • Actualiza a 5.3.0rc1
    Publicación Actualización
  5. CVE-2024-12029

    Crítica · CVSS 9.8EPSS 5,98%Código de explotación públicoCorrección disponible

    Remote Code Execution via Model Deserialization in invoke-ai/invokeai

    A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3.

    • Actualiza a 5.4.3rc1
    • Actualiza a 5.4.3rc2
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →