p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de mercurial

Vulnerabilidades publicadas para mercurial en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 18

  1. CVE-2014-9390

    Crítica · CVSS 9.8EPSS 75,6%Código de explotación públicoCorrección disponible

    CVE-2014-9390

    Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial before 3.2.3 on Windows and OS X; Apple Xcode before 6.2 beta 3; mine all versions before 08-12-2014; libgit2 all versions up to 0.21.2; Egit all versions before 08-12-2014; and JGit all versions before 08-12-2014 allow remote Git servers to execute arbitrary commands via a tree containing a crafted .git/config file with (1) an ignorable Unicode codepoint, (2) a git~1/config representation, or (3) mixed case that is improperly handled on a case-insensitive filesystem.

    • Actualiza a 3.2.3
    Publicación Actualización
  2. CVE-2010-4237

    Media · CVSS 5.9EPSS 0,82%Corrección disponible

    CVE-2010-4237

    Mercurial before 1.6.4 fails to verify the Common Name field of SSL certificates which allows remote attackers who acquire a certificate signed by a Certificate Authority to perform a man-in-the-middle attack.

    • Actualiza a 1.6.4
    Publicación Actualización
  3. CVE-2018-13348

    Alta · CVSS 8.7EPSS 2,1%Corrección disponible

    CVE-2018-13348

    The mpatch_decode function in mpatch.c in Mercurial before 4.6.1 mishandles certain situations where there should be at least 12 bytes remaining after the current position in the patch data, but actually are not, aka OVE-20180430-0001.

    • Actualiza a 4.6.1
    Publicación Actualización
  4. CVE-2018-1000132

    Crítica · CVSS 9.3EPSS 2,62%Corrección disponible

    CVE-2018-1000132

    Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.

    • Actualiza a 4.5.1
    Publicación Actualización
  5. CVE-2017-17458

    Crítica · CVSS 9.8EPSS 6,33%Corrección disponible

    CVE-2017-17458

    In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a .git/hooks/post-update script checked into the repository. Typical use of Mercurial prevents construction of such repositories, but they can be created programmatically.

    • Actualiza a 4.4.1
    Publicación Actualización
  6. CVE-2017-9462

    Alta · CVSS 8.8EPSS 21,68%Código de explotación públicoCorrección disponible

    CVE-2017-9462

    In Mercurial before 4.1.3, "hg serve --stdio" allows remote authenticated users to launch the Python debugger, and consequently execute arbitrary code, by using --debugger as a repository name.

    • Actualiza a 4.1.3
    Publicación Actualización
  7. CVE-2016-3630

    Alta · CVSS 8.8EPSS 4,87%Corrección disponible

    CVE-2016-3630

    The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull command, related to (a) a list sizing rounding error and (b) short records.

    • Actualiza a 3.7.3
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →