p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de pygeoapi

Vulnerabilidades publicadas para pygeoapi en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 2

  1. CVE-2026-42352

    Alta · CVSS 8.6EPSS 0,45%Corrección disponible

    pygeoapi 0.23.x: Unauthenticated SSRF via OGC API - Processes Subscriber

    pygeoapi is a Python server implementation of the OGC API suite of standards. From version 0.23.0 to before version 0.23.3, OGC API process execution requests can use the subscriber object to requests to internal HTTP services. This issue has been patched in version 0.23.3.

    • Actualiza a 0.23.3
    Publicación Actualización
  2. CVE-2026-42351

    Alta · CVSS 7.5EPSS 0,51%Corrección disponible

    pygeoapi: Path Traversal in STAC FileSystemProvider

    pygeoapi is a Python server implementation of the OGC API suite of standards. From version 0.23.0 to before version 0.23.3, a raw string path concatenation vulnerability in pygeoapi's STAC FileSystemProvider plugin can allow for requests to STAC collection based collections to expose directories without authentication. The issue manifests when pygeoapi is deployed without a proxy or web front end that would normalize URLs with .. values, along with a resource of type stac-collection defined in configuration. This issue has been patched in version 0.23.3.

    • Actualiza a 0.23.3
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →