p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de whoogle-search

Vulnerabilidades publicadas para whoogle-search en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 6

  1. CVE-2024-22417

    Media · CVSS 6.1EPSS 0,64%Corrección disponible

    Whoogle Search Cross-site Scripting vulnerability

    Whoogle Search is a self-hosted metasearch engine. In versions 0.8.3 and prior, the `element` method in `app/routes.py` does not validate the user-controlled `src_type` and `element_url` variables and passes them to the `send` method which sends a `GET` request on lines 339-343 in `requests.py`. The returned contents of the URL are then passed to and reflected back to the user in the `send_file` function on line 484, together with the user-controlled `src_type`, which allows the attacker to control the HTTP response content type leading to a cross-site scripting vulnerability. An attacker could craft a special URL to point to a malicious webs

    • Actualiza a 0.8.4
    Publicación Actualización
  2. CVE-2024-22205

    Crítica · CVSS 9.1EPSS 0,99%Corrección disponible

    Whoogle Search Server Side Request Forgery vulnerability

    Whoogle Search is a self-hosted metasearch engine. In versions 0.8.3 and prior, the `window` endpoint does not sanitize user-supplied input from the `location` variable and passes it to the `send` method which sends a `GET` request on lines 339-343 in `request.py,` which leads to a server-side request forgery. This issue allows for crafting GET requests to internal and external resources on behalf of the server. For example, this issue would allow for accessing resources on the internal network that the server has access to, even though these resources may not be accessible on the internet. This issue is fixed in version 0.8.4.

    • Actualiza a 0.8.4
    Publicación Actualización
  3. CVE-2024-22204

    Media · CVSS 5.3EPSS 0,76%Corrección disponible

    Whoogle Search Limited File Write vulnerability

    Whoogle Search is a self-hosted metasearch engine. Versions 0.8.3 and prior have a limited file write vulnerability when the configuration options in Whoogle are enabled. The `config` function in `app/routes.py` does not validate the user-controlled `name` variable on line 447 and `config_data` variable on line 437. The `name` variable is insecurely concatenated in `os.path.join`, leading to path manipulation. The POST data from the `config_data` variable is saved with `pickle.dump` which leads to a limited file write. However, the data that is saved is earlier transformed into a dictionary and the `url` key value pair is added before the fil

    • Actualiza a 0.8.4
    Publicación Actualización
  4. CVE-2024-22203

    Crítica · CVSS 9.1EPSS 1,01%Corrección disponible

    Whoogle Search Server Side Request Forgery vulnerability

    Whoogle Search is a self-hosted metasearch engine. In versions prior to 0.8.4, the `element` method in `app/routes.py` does not validate the user-controlled `src_type` and `element_url` variables and passes them to the `send` method which sends a GET request on lines 339-343 in `request.py`, which leads to a server-side request forgery. This issue allows for crafting GET requests to internal and external resources on behalf of the server. For example, this issue would allow for accessing resources on the internal network that the server has access to, even though these resources may not be accessible on the internet. This issue is fixed in ve

    • Actualiza a 0.8.4
    Publicación Actualización
  5. CVE-2022-25303

    Media · CVSS 5.4EPSS 0,97%Corrección disponible

    Cross-site Scripting (XSS)

    The package whoogle-search before 0.7.2 are vulnerable to Cross-site Scripting (XSS) via the query string parameter q. In the case where it does not contain the http string, it is used to build the error_message that is then rendered in the error.html template, using the [flask.render_template](https://flask.palletsprojects.com/en/2.1.x/api/flask.render_template) function. However, the error_message is rendered using the [| safe filter](https://jinja.palletsprojects.com/en/3.1.x/templates/working-with-automatic-escaping), meaning the user input is not escaped.

    • Actualiza a 0.7.2
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →