p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de xgrammar

Vulnerabilidades publicadas para xgrammar en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 4

  1. CVE-2026-25048

    Alta · CVSS 8.7EPSS 1,32%Corrección disponible

    xgrammar: Multi-layer nesting causes DoS

    xgrammar is an open-source library for efficient, flexible, and portable structured generation. Prior to version 0.1.32, the multi-level nested syntax caused a segmentation fault (core dumped). This issue has been patched in version 0.1.32.

    • Actualiza a 0.1.32
    Publicación Actualización
  2. CVE-2025-58446

    Media · CVSS 6.9EPSS 0,62%Corrección disponible

    xgrammar vulnerable to denial of service by huge enum grammar

    xgrammar is an open-source library for efficient, flexible, and portable structured generation. A grammar optimizer introduced in 0.1.23 processes large grammars (>100k characters) at very low rates, and can be used for DOS of model providers. This issue is fixed in version 0.1.24.

    • Actualiza a 0.1.24
    Publicación Actualización
  3. CVE-2025-57809

    Alta · CVSS 7.7EPSS 0,48%Corrección disponible

    XGrammar affected by Denial of Service by infinite recursion grammars

    XGrammar is an open-source library for efficient, flexible, and portable structured generation. Prior to version 0.1.21, XGrammar has an infinite recursion issue in the grammar. This issue has been resolved in version 0.1.21.

    • Actualiza a 0.1.21
    Publicación Actualización
  4. CVE-2025-32381

    Media · CVSS 6.5EPSS 0,52%Corrección disponible

    Denial of Service by abusing xgrammar unbounded cache in memory

    XGrammar is an open-source library for efficient, flexible, and portable structured generation. Prior to 0.1.18, Xgrammar includes a cache for compiled grammars to increase performance with repeated use of the same grammar. This cache is held in memory. Since the cache is unbounded, a system making use of xgrammar can be abused to fill up a host's memory and case a denial of service. For example, sending many small requests to an LLM inference server with unique JSON schemas would eventually cause this denial of service to occur. This vulnerability is fixed in 0.1.18.

    • Actualiza a 0.1.18
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →