SUSE-SU-2022:1431-1
SUSE-SU-2022:1431-1 · Security update for webkit2gtk3
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
This update for webkit2gtk3 fixes the following issues: Update to version 2.36.0 (bsc#1198290): - CVE-2022-22624: Fixed use after free that may lead to arbitrary code execution. - CVE-2022-22628: Fixed use after free that may lead to arbitrary code execution. - CVE-2022-22629: Fixed a buffer overflow that may lead to arbitrary code execution. - CVE-2022-22637: Fixed an unexpected cross-origin behavior due to a logic error. Missing CVE reference for the update to 2.34.6 (bsc#1196133): - CVE-2022-22594: Fixed a cross-origin issue in the IndexDB API.
Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
webkit2gtk3 SUSE:Linux Enterprise Module for Basesystem 15 SP3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.36.0-150200.32.1
Actualiza a 2.36.0-150200.32.1
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.36.0-150200.32.1
Actualiza a 2.36.0-150200.32.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.36.0-150200.32.1
Actualiza a 2.36.0-150200.32.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.36.0-150200.32.1
Actualiza a 2.36.0-150200.32.1
webkit2gtk3 SUSE:Linux Enterprise Real Time 15 SP2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.36.0-150200.32.1
Actualiza a 2.36.0-150200.32.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP2-BCL
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.36.0-150200.32.1
Actualiza a 2.36.0-150200.32.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP2-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.36.0-150200.32.1
Actualiza a 2.36.0-150200.32.1
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.36.0-150200.32.1
Actualiza a 2.36.0-150200.32.1
webkit2gtk3 SUSE:Manager Proxy 4.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.36.0-150200.32.1
Actualiza a 2.36.0-150200.32.1
webkit2gtk3 SUSE:Manager Retail Branch Server 4.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.36.0-150200.32.1
Actualiza a 2.36.0-150200.32.1
webkit2gtk3 SUSE:Manager Server 4.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.36.0-150200.32.1
Actualiza a 2.36.0-150200.32.1
webkit2gtk3 SUSE:Enterprise Storage 7
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.36.0-150200.32.1
Actualiza a 2.36.0-150200.32.1
webkit2gtk3 openSUSE:Leap 15.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.36.0-150200.32.1
Actualiza a 2.36.0-150200.32.1
webkit2gtk3 openSUSE:Leap 15.4
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.36.0-150200.32.1
Actualiza a 2.36.0-150200.32.1
Fuentes originales
- https://www.suse.com/support/update/announcement/2022/suse-su-20221431-1/
- https://bugzilla.suse.com/1196133
- https://bugzilla.suse.com/1198290
- https://www.suse.com/security/cve/CVE-2022-22594
- https://www.suse.com/security/cve/CVE-2022-22624
- https://www.suse.com/security/cve/CVE-2022-22628
- https://www.suse.com/security/cve/CVE-2022-22629
- https://www.suse.com/security/cve/CVE-2022-22637
- https://osv.dev/vulnerability/SUSE-SU-2022:1431-1