p PatchFirst

SUSE-SU-2022:2820-1

SUSE-SU-2022:2820-1 · Security update for webkit2gtk3

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

This update for webkit2gtk3 fixes the following issues: - Update to version 2.36.5 (bsc#1201980): - Add support for PAC proxy in the WebDriver implementation. - Fix video playback when loaded through custom URIs, this fixes video playback in the Yelp documentation browser. - Fix WebKitWebView::context-menu when using GTK4. - Fix LTO builds with GCC. - Fix several crashes and rendering issues. - Security fixes: - CVE-2022-32792: Fixed processing maliciously crafted web content may lead to arbitrary code execution. - CVE-2022-32816: Fixed visiting a website that frames malicious content may lead to UI spoofing.

Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • webkit2gtk3 SUSE:Linux Enterprise Module for Basesystem 15 SP3

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.36.5-150200.41.1

    Actualiza a 2.36.5-150200.41.1

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP3

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.36.5-150200.41.1

    Actualiza a 2.36.5-150200.41.1

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.36.5-150200.41.1

    Actualiza a 2.36.5-150200.41.1

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.36.5-150200.41.1

    Actualiza a 2.36.5-150200.41.1

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP2-BCL

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.36.5-150200.41.1

    Actualiza a 2.36.5-150200.41.1

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP2-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.36.5-150200.41.1

    Actualiza a 2.36.5-150200.41.1

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP2

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.36.5-150200.41.1

    Actualiza a 2.36.5-150200.41.1

  • webkit2gtk3 SUSE:Manager Proxy 4.1

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.36.5-150200.41.1

    Actualiza a 2.36.5-150200.41.1

  • webkit2gtk3 SUSE:Manager Retail Branch Server 4.1

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.36.5-150200.41.1

    Actualiza a 2.36.5-150200.41.1

  • webkit2gtk3 SUSE:Manager Server 4.1

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.36.5-150200.41.1

    Actualiza a 2.36.5-150200.41.1

  • webkit2gtk3 SUSE:Enterprise Storage 7

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.36.5-150200.41.1

    Actualiza a 2.36.5-150200.41.1

  • webkit2gtk3 openSUSE:Leap 15.3

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.36.5-150200.41.1

    Actualiza a 2.36.5-150200.41.1

  • webkit2gtk3 openSUSE:Leap 15.4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.36.5-150200.41.1

    Actualiza a 2.36.5-150200.41.1

Fuentes originales

Comprueba tu servidor →