SUSE-SU-2022:4207-1
SUSE-SU-2022:4207-1 · Security update for webkit2gtk3
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Security fixes: - CVE-2022-32888: Fixed possible arbitrary code execution via maliciously crafted web content (bsc#1205121). - CVE-2022-32923: Fixed possible information leak via maliciously crafted web content (bsc#1205122). - CVE-2022-42799: Fixed user interface spoofing when visiting a malicious website (bsc#1205123). - CVE-2022-42823: Fixed possible arbitrary code execution via maliciously crafted web content (bsc#1205120). - CVE-2022-42824: Fixed possible sensitive user information leak via maliciously crafted web content (bsc#1205124). Update to version 2.38.2: - Fix scrolling issues in some sites having fixed background. - Fix prolonged buffering during progressive live playback. - Fix the build with accessibility disabled. - Fix several crashes and rendering issues. Update to version 2.38.1: - Make xdg-dbus-proxy work if host session bus address is an abstract socket. - Use a single xdg-dbus-proxy process when sandbox is enabled. - Fix high resolution video playback due to unimplemented changeType operation. - Ensure GSubprocess uses posix_spawn() again and inherit file descriptors. - Fix player stucking in buffering (paused) state for progressive streaming. - Do not try to preconnect on link click when link preconnect setting is disabled. - Fix close status code returned when the client closes a WebSocket in some cases. - Fix media player duration calculation. - Fix several crashes and rendering issues. Update to version 2.38.0: - New media controls UI style. - Add new API to set WebView's Content-Security-Policy for web extensions support. - Make it possible to use the remote inspector from other browsers using WEBKIT_INSPECTOR_HTTP_SERVER env var. - MediaSession is enabled by default, allowing remote media control using MPRIS. - Add support for PDF documents using PDF.js.
Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP4
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.38.2-150400.4.22.1
Actualiza a 2.38.2-150400.4.22.1
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP4
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.38.2-150400.4.22.1
Actualiza a 2.38.2-150400.4.22.1
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP4
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.38.2-150400.4.22.1
Actualiza a 2.38.2-150400.4.22.1
webkit2gtk3 openSUSE:Leap 15.4
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.38.2-150400.4.22.1
Actualiza a 2.38.2-150400.4.22.1
webkit2gtk3-soup2 openSUSE:Leap 15.4
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.38.2-150400.4.22.1
Actualiza a 2.38.2-150400.4.22.1
webkit2gtk4 openSUSE:Leap 15.4
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.38.2-150400.4.22.1
Actualiza a 2.38.2-150400.4.22.1
Fuentes originales
- https://www.suse.com/support/update/announcement/2022/suse-su-20224207-1/
- https://bugzilla.suse.com/1205120
- https://bugzilla.suse.com/1205121
- https://bugzilla.suse.com/1205122
- https://bugzilla.suse.com/1205123
- https://bugzilla.suse.com/1205124
- https://www.suse.com/security/cve/CVE-2022-32888
- https://www.suse.com/security/cve/CVE-2022-32923
- https://www.suse.com/security/cve/CVE-2022-42799
- https://www.suse.com/security/cve/CVE-2022-42823
- https://www.suse.com/security/cve/CVE-2022-42824
- https://osv.dev/vulnerability/SUSE-SU-2022:4207-1