SUSE-SU-2024:3091-1
SUSE-SU-2024:3091-1 · Security update for webkit2gtk3
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
This update for webkit2gtk3 fixes the following issues: Update to version 2.44.3 (bsc#1228696 bsc#1228697 bsc#1228698): - Fix web process cache suspend/resume when sandbox is enabled. - Fix accelerated images dissapearing after scrolling. - Fix video flickering with DMA-BUF sink. - Fix pointer lock on X11. - Fix movement delta on mouse events in GTK3. - Undeprecate console message API and make it available in 2022 API. - Fix several crashes and rendering issues. - Security fixes: CVE-2024-40776, CVE-2024-40779, CVE-2024-40780, CVE-2024-40782, CVE-2024-40785, CVE-2024-40789, CVE-2024-40794, CVE-2024-4558.
Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk4 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk3-soup2 SUSE:Manager Proxy 4.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk3-soup2 SUSE:Manager Server 4.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk3 openSUSE:Leap 15.5
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk3-soup2 openSUSE:Leap 15.5
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
webkit2gtk4 openSUSE:Leap 15.5
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.3-150400.4.88.1
Actualiza a 2.44.3-150400.4.88.1
Fuentes originales
- https://www.suse.com/support/update/announcement/2024/suse-su-20243091-1/
- https://bugzilla.suse.com/1228613
- https://bugzilla.suse.com/1228693
- https://bugzilla.suse.com/1228694
- https://bugzilla.suse.com/1228695
- https://bugzilla.suse.com/1228696
- https://bugzilla.suse.com/1228697
- https://bugzilla.suse.com/1228698
- https://www.suse.com/security/cve/CVE-2024-40776
- https://www.suse.com/security/cve/CVE-2024-40779
- https://www.suse.com/security/cve/CVE-2024-40780
- https://www.suse.com/security/cve/CVE-2024-40782
- https://www.suse.com/security/cve/CVE-2024-40785
- https://www.suse.com/security/cve/CVE-2024-40789
- https://www.suse.com/security/cve/CVE-2024-40794
- https://www.suse.com/security/cve/CVE-2024-4558
- https://osv.dev/vulnerability/SUSE-SU-2024:3091-1