p PatchFirst

SUSE-SU-2025:02049-1

SUSE-SU-2025:02049-1 · Security update for python311

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.

This update for python311 fixes the following issues: python311 was updated from version 3.11.10 to 3.11.13: - Security issues fixed: * CVE-2025-4516: Fixed blocking DecodeError handling vulnerability, which could lead to DoS (bsc#1243273). * CVE-2024-12718, CVE-2025-4138, CVE-2025-4330, CVE-2025-4517: Fixed multiple issues that allowed tarfile extraction filters to be bypassed using crafted symlinks and hard links (bsc#1244056, bsc#1244059, bsc#1244060, bsc#1244032) - Other bugs fixed: * Improved handling of system call failures that OpenSSL reports (bsc#1241067) * Disable GC during thread operations to prevent deadlocks. * Fixed a potential denial of service vulnerability in the imaplib module. * Fixed bugs in the in the folding of rfc2047 encoded-words and in the folding of quoted strings when flattening an email message using a modern email policy. * Fixed parsing long IPv6 addresses with embedded IPv4 address. * Fixed ipaddress.IPv6Address.reverse_pointer output according to RFC 3596. * Improved the textual representation of IPv4-mapped IPv6 addresses in ipaddress. * ipaddress: fixed hash collisions for IPv4Network and IPv6Network objects * os.path.realpath() now accepts a strict keyword-only argument. * Stop the processing of long IPv6 addresses early in ipaddress to prevent excessive memory consumption and a minor denial-of-service. * Updated bundled libexpat to 2.7.1 * Writers of CPython documentation can now use next as the version for the versionchanged, versionadded, deprecated directives.

Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • python311 SUSE:Linux Enterprise Module for Public Cloud 15 SP4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-core SUSE:Linux Enterprise Module for Public Cloud 15 SP4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-core SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-documentation SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-core SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-documentation SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-core SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-documentation SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-core SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-documentation SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-core SUSE:Linux Enterprise Server 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-documentation SUSE:Linux Enterprise Server 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311 SUSE:Linux Enterprise Server 15 SP5-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-core SUSE:Linux Enterprise Server 15 SP5-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-documentation SUSE:Linux Enterprise Server 15 SP5-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-core SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311-documentation SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

  • python311 SUSE:Linux Enterprise Server for SAP Applications 15 SP5

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.13-150400.9.60.1

    Actualiza a 3.11.13-150400.9.60.1

Fuentes originales

Comprueba tu servidor →