SUSE-SU-2025:03545-1
SUSE-SU-2025:03545-1 · Security update for docker-stable
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.
This update for docker-stable fixes the following issues: Note this update contains a already fixed references mostly. - Remove git-core recommends on SLE to avoid pulling it in unnecessary. (bsc#1250508) This feature is mostly intended for developers ('docker build git://') so most users already have the dependency installed, and the error when git is missing is fairly straightforward (so they can easily figure out what they need to install). - Include historical changelog data from before the docker-stable fork. The initial changelog entry did technically provide all the necessary information, but our CVE tracking tools do not understand how the package is forked and so it seems that this package does not include fixes for ~12 years of updates. So, include a copy of the original package's changelog up until the fork point. bsc#1250596 - Update to docker-buildx v0.25.0. Upstream changelog: <https://github.com/docker/buildx/releases/tag/v0.25.0> - Update to Go 1.23 for building now that upstream has switched their 23.0.x LTSS to use Go 1.23. - Do not try to inject SUSEConnect secrets when in Rootless Docker mode, as Docker does not have permission to access the host zypper credentials in this mode (and unprivileged users cannot disable the feature using /etc/docker/suse-secrets-enable.) bsc#1240150 - Initial docker-stable fork, forked from Docker 24.0.7-ce release (packaged on 2024-02-14). The original changelog is included below for historical reference.
Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
docker-stable SUSE:Linux Enterprise Module for Containers 15 SP6
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
docker-stable SUSE:Linux Enterprise Module for Containers 15 SP7
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
docker-stable SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
docker-stable SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
docker-stable SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
docker-stable SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
docker-stable SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
docker-stable SUSE:Linux Enterprise Server 15 SP3-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
docker-stable SUSE:Linux Enterprise Server 15 SP4-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
docker-stable SUSE:Linux Enterprise Server 15 SP5-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
docker-stable SUSE:Linux Enterprise Server for SAP Applications 15 SP3
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
docker-stable SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
docker-stable SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
docker-stable SUSE:Enterprise Storage 7.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
docker-stable openSUSE:Leap 15.6
- Intervalos de versiones afectados
- ECOSYSTEM: < 24.0.9_ce-150000.1.25.1
Actualiza a 24.0.9_ce-150000.1.25.1
Fuentes originales
- https://www.suse.com/support/update/announcement/2025/suse-su-202503545-1/
- https://bugzilla.suse.com/1001161
- https://bugzilla.suse.com/1004490
- https://bugzilla.suse.com/1007249
- https://bugzilla.suse.com/1009961
- https://bugzilla.suse.com/1012568
- https://bugzilla.suse.com/1015661
- https://bugzilla.suse.com/1016307
- https://bugzilla.suse.com/1016992
- https://bugzilla.suse.com/1019251
- https://bugzilla.suse.com/1020806
- https://bugzilla.suse.com/1021227
- https://bugzilla.suse.com/1026827
- https://bugzilla.suse.com/1028638
- https://bugzilla.suse.com/1028639
- https://bugzilla.suse.com/1029320
- https://bugzilla.suse.com/1029630
- https://bugzilla.suse.com/1030702
- https://bugzilla.suse.com/1032287
- https://bugzilla.suse.com/1032644
- https://bugzilla.suse.com/1034053
- https://bugzilla.suse.com/1034063
- https://bugzilla.suse.com/1037436
- https://osv.dev/vulnerability/SUSE-SU-2025:03545-1