SUSE-SU-2025:0691-1
SUSE-SU-2025:0691-1 · Security update for webkit2gtk3
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
This update for webkit2gtk3 fixes the following issues: Update to version 2.46.6 (bsc#1236946): - CVE-2025-24143: A maliciously crafted webpage may be able to fingerprint the user. - CVE-2025-24150: Copying a URL from Web Inspector may lead to command injection. - CVE-2025-24158: Processing web content may lead to a denial-of-service. - CVE-2025-24162: Processing maliciously crafted web content may lead to an unexpected process crash. Already fixed in previous releases: - CVE-2024-54543: Processing maliciously crafted web content may lead to memory corruption. - CVE-2024-27856: Processing a file may lead to unexpected app termination or arbitrary code execution. - CVE-2024-54658: Processing web content may lead to a denial-of-service.
Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.46.6-150600.12.27.1
Actualiza a 2.46.6-150600.12.27.1
webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.46.6-150600.12.27.1
Actualiza a 2.46.6-150600.12.27.1
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP6
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.46.6-150600.12.27.1
Actualiza a 2.46.6-150600.12.27.1
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP6
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.46.6-150600.12.27.1
Actualiza a 2.46.6-150600.12.27.1
webkit2gtk3 openSUSE:Leap 15.6
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.46.6-150600.12.27.1
Actualiza a 2.46.6-150600.12.27.1
webkit2gtk3-soup2 openSUSE:Leap 15.6
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.46.6-150600.12.27.1
Actualiza a 2.46.6-150600.12.27.1
webkit2gtk4 openSUSE:Leap 15.6
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.46.6-150600.12.27.1
Actualiza a 2.46.6-150600.12.27.1
Fuentes originales
- https://www.suse.com/support/update/announcement/2025/suse-su-20250691-1/
- https://bugzilla.suse.com/1236946
- https://www.suse.com/security/cve/CVE-2024-27856
- https://www.suse.com/security/cve/CVE-2024-54543
- https://www.suse.com/security/cve/CVE-2024-54658
- https://www.suse.com/security/cve/CVE-2025-24143
- https://www.suse.com/security/cve/CVE-2025-24150
- https://www.suse.com/security/cve/CVE-2025-24158
- https://www.suse.com/security/cve/CVE-2025-24162
- https://osv.dev/vulnerability/SUSE-SU-2025:0691-1