p PatchFirst

SUSE-SU-2026:1364-1

SUSE-SU-2026:1364-1 · Security update for webkit2gtk3

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.

This update for webkit2gtk3 fixes the following issues: Update to version 2.52.0. Security issues fixed: - CVE-2023-43010: processing maliciously crafted web content may lead to memory corruption (bsc#1259950). - CVE-2025-31223: processing maliciously crafted web content may lead to memory corruption (bsc#1259949). - CVE-2025-31277: processing maliciously crafted web content may lead to memory corruption (bsc#1259948). - CVE-2025-43213: processing maliciously crafted web content may lead to an unexpected crash (bsc#1259947). - CVE-2025-43214: processing maliciously crafted web content may lead to an unexpected crash (bsc#1259946). - CVE-2025-43433: processing maliciously crafted web content may lead to memory corruption (bsc#1259945). - CVE-2025-43438: processing maliciously crafted web content may lead to an unexpected crash (bsc#1259944). - CVE-2025-43441: processing maliciously crafted web content may lead to an unexpected process crash (bsc#1259943). - CVE-2025-43457: processing maliciously crafted web content may lead to an unexpected crash (bsc#1259942). - CVE-2025-43511: processing maliciously crafted web content may lead to an unexpected process crash (bsc#1259941). - CVE-2025-46299: processing maliciously crafted web content may disclose internal states of an app (bsc#1259940). - CVE-2026-20608: processing maliciously crafted web content may lead to an unexpected process crash (bsc#1259939). - CVE-2026-20635: processing maliciously crafted web content may lead to an unexpected process crash (bsc#1259938). - CVE-2026-20636: processing maliciously crafted web content may lead to an unexpected process crash (bsc#1259937). - CVE-2026-20643: processing maliciously crafted web content may bypass Same Origin Policy (bsc#1261172). - CVE-2026-20644: processing maliciously crafted web content may lead to an unexpected process crash (bsc#1259936). - CVE-2026-20652: a remote attacker may be able to cause a denial-of-service (bsc#1259935). - CVE-2026-20664: processing maliciously crafted web content may lead to an unexpected process crash (bsc#1261173). - CVE-2026-20665: processing maliciously crafted web content may prevent Content Security Policy from being enforced (bsc#1261174). - CVE-2026-20676: a website may be able to track users through web extensions (bsc#1259934). - CVE-2026-20691: a maliciously crafted webpage may be able to fingerprint the user (bsc#1261175). - CVE-2026-28857: processing maliciously crafted web content may lead to an unexpected process crash (bsc#1261176). - CVE-2026-28859: a malicious website may be able to process restricted web content outside the sandbox (bsc#1261177). - CVE-2026-28861: a malicious website may be able to access script message handlers intended for other origins (bsc#1261178). - CVE-2026-28871: visiting a maliciously crafted website may lead to a cross-site scripting attack (bsc#1261179). Other updates and bugfixes: - Make scrolling with touch input smoother for small movements. - Fix estimated load progress of downloads when Content-Length value is wrong. - Ensure that 'scrollend' events are correctly emitted after scroll animations. - Reduce the amount of useless MPRIS notifications produced by MediaSession when the information about media being played is incomplete. - Support turning off USE_GSTREAMER to configure the build with all multimedia features disabled. - Add Sysprof marks for mouse events. - Fix MediaSession icon for iheart.com not being displayed. - Fix the build with USE_GSTREAMER_GL disabled. - Fix the build with librice version 0.3.0 or newer. - Fix several crashes and rendering issues. - Translation updates: Georgian.

Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP7

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.52.1-150600.12.63.1

    Actualiza a 2.52.1-150600.12.63.1

  • webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP7

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.52.1-150600.12.63.1

    Actualiza a 2.52.1-150600.12.63.1

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP7

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.52.1-150600.12.63.1

    Actualiza a 2.52.1-150600.12.63.1

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP7

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.52.1-150600.12.63.1

    Actualiza a 2.52.1-150600.12.63.1

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP6-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.52.1-150600.12.63.1

    Actualiza a 2.52.1-150600.12.63.1

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP6-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.52.1-150600.12.63.1

    Actualiza a 2.52.1-150600.12.63.1

  • webkit2gtk4 SUSE:Linux Enterprise Server 15 SP6-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.52.1-150600.12.63.1

    Actualiza a 2.52.1-150600.12.63.1

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP6

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.52.1-150600.12.63.1

    Actualiza a 2.52.1-150600.12.63.1

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP6

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.52.1-150600.12.63.1

    Actualiza a 2.52.1-150600.12.63.1

  • webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP6

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.52.1-150600.12.63.1

    Actualiza a 2.52.1-150600.12.63.1

  • webkit2gtk3 openSUSE:Leap 15.6

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.52.1-150600.12.63.1

    Actualiza a 2.52.1-150600.12.63.1

  • webkit2gtk3-soup2 openSUSE:Leap 15.6

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.52.1-150600.12.63.1

    Actualiza a 2.52.1-150600.12.63.1

  • webkit2gtk4 openSUSE:Leap 15.6

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.52.1-150600.12.63.1

    Actualiza a 2.52.1-150600.12.63.1

Fuentes originales

Comprueba tu servidor →