SUSE-SU-2026:2378-1
SUSE-SU-2026:2378-1 · Security update for webkit2gtk3
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.
This update for webkit2gtk3 fixes the following issues Update to version 2.52.4: - CVE-2026-28847: processing maliciously crafted web content may lead to an unexpected process crash or arbitrary code execution due to a heap buffer overflow (bsc#1267506). - CVE-2026-28883: processing maliciously crafted web content may lead to an unexpected process crash due to a use-after- free issue (bsc#1267507). - CVE-2026-28901: processing maliciously crafted web content may lead to an unexpected process crash due to improper memory handling (bsc#1267508). - CVE-2026-28902: processing maliciously crafted web content may lead to an unexpected process crash due to improper memory handling (bsc#1267509). - CVE-2026-28903: processing maliciously crafted web content may lead to an unexpected process crash due to improper memory handling (bsc#1267510). - CVE-2026-28904: processing maliciously crafted web content may lead to an unexpected process crash due to improper memory handling (bsc#1267511). - CVE-2026-28905: processing maliciously crafted web content may lead to an unexpected process crash due to improper memory handling (bsc#1267512). - CVE-2026-28907: processing maliciously crafted web content may prevent Content Security Policy from being enforced due to improper input validation (bsc#1267513). - CVE-2026-28942: processing maliciously crafted web content may lead to an unexpected crash due to use-after-free (bsc#1267514). - CVE-2026-28946: processing maliciously crafted web content may lead to an unexpected crash due to a use-after-free (bsc#1267515). - CVE-2026-28947: rocessing maliciously crafted web content may lead to an unexpected crash due to a use-after-free (bsc#1267516). - CVE-2026-28953: processing maliciously crafted web content may lead to an unexpected process crash due to improper memory handling (bsc#1267517). - CVE-2026-28955: processing maliciously crafted web content may lead to an unexpected process crash due to improper memory handling (bsc#1267518). - CVE-2026-28958: an app may be able to access sensitive user data due to improper data protection (bsc#1267519). - CVE-2026-43658: processing maliciously crafted web content may lead to an unexpected crash due to improper memory handling (bsc#1267520). - CVE-2026-43660: processing maliciously crafted web content may prevent Content Security Policy from being enforced due to issues with logic (bsc#1267521). Changes: + Add support for half-width fonts. + Improve content filter compilation by avoiding file copies. + Improve handling of out of disk space conditions when the NetworkProcess tried to write data in caches. + Improve how the CMake build system checks whether libatomic is required. + Fix painting scrollbars when their width changes. + Fix playback of certain YouTube videos with low frame rates. + Fix webkit://gpu not working in systems where neither libGL.so.1 nor libOpenGL.so.0 are available. + Fix the build with librice 0.4 or newer when the GStreamer WebRTC backend is enabled at build configuration time. + Fix the build with USE_GSTREAMER_WEBRTC=OFF. + Fix the build with USE_GBM=OFF. + Fix several crashes and rendering issues. + Add support for the 'scrollbar-color' CSS property. + Fix some emoji glyphs being rendered as missing glyph boxes. + Fix JavaScriptCore crashes on architectures other than x86_64. + Fix the build on s390x. + Changes in version 2.52.2: + Improve handling of real-time threads. + Fix scrollbar rendering glitches visible in some GPU configurations. + Fix V4L2 hardware accelerated media codecs now working due to overly restrictive sandbox device access rules. + Fix leak of bitmap images in webkit_favicon_database_get_favicon_finish(). + Fix the build with USE_GTK4=OFF.
Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
webkit2gtk4 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
webkit2gtk4 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.4-150400.4.143.1
Actualiza a 2.52.4-150400.4.143.1
Fuentes originales
- https://www.suse.com/support/update/announcement/2026/suse-su-20262378-1/
- https://bugzilla.suse.com/1267506
- https://bugzilla.suse.com/1267507
- https://bugzilla.suse.com/1267508
- https://bugzilla.suse.com/1267509
- https://bugzilla.suse.com/1267510
- https://bugzilla.suse.com/1267511
- https://bugzilla.suse.com/1267512
- https://bugzilla.suse.com/1267513
- https://bugzilla.suse.com/1267514
- https://bugzilla.suse.com/1267515
- https://bugzilla.suse.com/1267516
- https://bugzilla.suse.com/1267517
- https://bugzilla.suse.com/1267518
- https://bugzilla.suse.com/1267519
- https://bugzilla.suse.com/1267520
- https://bugzilla.suse.com/1267521
- https://www.suse.com/security/cve/CVE-2026-28847
- https://www.suse.com/security/cve/CVE-2026-28883
- https://www.suse.com/security/cve/CVE-2026-28901
- https://www.suse.com/security/cve/CVE-2026-28902
- https://www.suse.com/security/cve/CVE-2026-28903
- https://www.suse.com/security/cve/CVE-2026-28904
- https://osv.dev/vulnerability/SUSE-SU-2026:2378-1