p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de pygments

Vulnerabilidades publicadas para pygments en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 3

  1. CVE-2026-4539

    Media · CVSS 4.8EPSS 0,16%Sin corrección publicada

    pygments archetype.py AdlLexer redos

    A security flaw has been discovered in pygments up to 2.19.2. The impacted element is the function AdlLexer of the file pygments/lexers/archetype.py. The manipulation results in inefficient regular expression complexity. The attack is only possible with local access. The exploit has been released to the public and may be used for attacks. The project was informed of the problem early through an issue report but has not responded yet.

    Publicación Actualización
  2. CVE-2021-27291

    Alta · CVSS 8.7EPSS 3,91%Corrección disponible

    CVE-2021-27291

    In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.

    • Actualiza a 2.1+dfsg-1ubuntu0.2
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →