p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de glibc

Vulnerabilidades publicadas para glibc en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 18

  1. CVE-2021-3999

    Alta · CVSS 7.8EPSS 0,81%Corrección disponible

    CVE-2021-3999

    A flaw was found in glibc. An off-by-one buffer overflow and underflow in getcwd() may lead to memory corruption when the size of the buffer is exactly 1. A local attacker who can control the input buffer and size passed to getcwd() in a setuid program could use this flaw to potentially execute arbitrary code and escalate their privileges on the system.

    • Actualiza a 2.27-3ubuntu1.5
    Publicación Actualización
  2. CVE-2022-23219

    Crítica · CVSS 9.8EPSS 4,69%Corrección disponible

    CVE-2022-23219

    The deprecated compatibility function clnt_create in the sunrpc module of the GNU C Library (aka glibc) through 2.34 copies its hostname argument on the stack without validating its length, which may result in a buffer overflow, potentially resulting in a denial of service or (if an application is not built with a stack protector enabled) arbitrary code execution.

    • Actualiza a 2.27-3ubuntu1.5
    Publicación Actualización
  3. CVE-2022-23218

    Crítica · CVSS 9.8EPSS 5,26%Corrección disponible

    CVE-2022-23218

    The deprecated compatibility function svcunix_create in the sunrpc module of the GNU C Library (aka glibc) through 2.34 copies its path argument on the stack without validating its length, which may result in a buffer overflow, potentially resulting in a denial of service or (if an application is not built with a stack protector enabled) arbitrary code execution.

    • Actualiza a 2.27-3ubuntu1.5
    Publicación Actualización
  4. CVE-2021-35942

    Crítica · CVSS 9.1EPSS 2,75%Corrección disponible

    CVE-2021-35942

    The wordexp function in the GNU C Library (aka glibc) through 2.33 may crash or read arbitrary memory in parse_param (in posix/wordexp.c) when called with an untrusted, crafted pattern, potentially resulting in a denial of service or disclosure of information. This occurs because atoi was used but strtoul should have been used to ensure correct calculations.

    • Actualiza a 2.27-3ubuntu1.5
    Publicación Actualización
  5. CVE-2020-27618

    Media · CVSS 5.5EPSS 0,94%Corrección disponible

    CVE-2020-27618

    The iconv function in the GNU C Library (aka glibc or libc6) 2.32 and earlier, when processing invalid multi-byte input sequences in IBM1364, IBM1371, IBM1388, IBM1390, and IBM1399 encodings, fails to advance the input state, which could lead to an infinite loop in applications, resulting in a denial of service, a different vulnerability from CVE-2016-10228.

    • Actualiza a 2.27-3ubuntu1.5
    Publicación Actualización
  6. CVE-2021-3326

    Alta · CVSS 7.5EPSS 3,82%Corrección disponible

    CVE-2021-3326

    The iconv function in the GNU C Library (aka glibc or libc6) 2.32 and earlier, when processing invalid input sequences in the ISO-2022-JP-3 encoding, fails an assertion in the code path and aborts the program, potentially resulting in a denial of service.

    • Actualiza a 2.27-3ubuntu1.5
    Publicación Actualización
  7. CVE-2020-29562

    Media · CVSS 4.8EPSS 1,68%Corrección disponible

    CVE-2020-29562

    The iconv function in the GNU C Library (aka glibc or libc6) 2.30 to 2.32, when converting UCS4 text containing an irreversible character, fails an assertion in the code path and aborts the program, potentially resulting in a denial of service.

    • Actualiza a 2.27-3ubuntu1.5
    Publicación Actualización
  8. CVE-2020-1752

    Alta · CVSS 7EPSS 0,55%Corrección disponible

    CVE-2020-1752

    A use-after-free vulnerability introduced in glibc upstream version 2.14 was found in the way the tilde expansion was carried out. Directory paths containing an initial tilde followed by a valid username were affected by this issue. A local attacker could exploit this flaw by creating a specially crafted path that, when processed by the glob function, would potentially lead to arbitrary code execution. This was fixed in version 2.32.

    • Actualiza a 2.27-3ubuntu1.2
    Publicación Actualización
  9. CVE-2020-1751

    Media · CVSS 5.1EPSS 0,54%Corrección disponible

    CVE-2020-1751

    An out-of-bounds write vulnerability was found in glibc before 2.31 when handling signal trampolines on PowerPC. Specifically, the backtrace function did not properly check the array bounds when storing the frame address, resulting in a denial of service or potential code execution. The highest threat from this vulnerability is to system availability.

    • Actualiza a 2.27-3ubuntu1.2
    Publicación Actualización
  10. CVE-2020-6096

    Alta · CVSS 8.1EPSS 5,48%Corrección disponible

    CVE-2020-6096

    An exploitable signed comparison vulnerability exists in the ARMv7 memcpy() implementation of GNU glibc 2.30.9000. Calling memcpy() (on ARMv7 targets that utilize the GNU glibc implementation) with a negative value for the 'num' parameter results in a signed comparison vulnerability. If an attacker underflows the 'num' parameter to memcpy(), this vulnerability could lead to undefined behavior such as writing to out-of-bounds memory and potentially remote code execution. Furthermore, this memcpy() implementation allows for program execution to continue in scenarios where a segmentation fault or crash should have occurred. The dangers occur in

    • Actualiza a 2.27-3ubuntu1.5
    Publicación Actualización
  11. CVE-2020-10029

    Media · CVSS 5.5EPSS 0,76%Corrección disponible

    CVE-2020-10029

    The GNU C Library (aka glibc or libc6) before 2.32 could overflow an on-stack buffer during range reduction if an input to an 80-bit long double function contains a non-canonical bit pattern, a seen when passing a 0x5d414141414141410000 value to sinl on x86 targets. This is related to sysdeps/ieee754/ldbl-96/e_rem_pio2l.c.

    • Actualiza a 2.27-3ubuntu1.2
    Publicación Actualización
  12. CVE-2019-19126

    Baja · CVSS 3.3EPSS 0,41%Corrección disponible

    CVE-2019-19126

    On the x86-64 architecture, the GNU C Library (aka glibc) before 2.31 fails to ignore the LD_PREFER_MAP_32BIT_EXEC environment variable during program execution after a security transition, allowing local attackers to restrict the possible mapping addresses for loaded libraries and thus bypass ASLR for a setuid program.

    • Actualiza a 2.27-3ubuntu1.2
    Publicación Actualización
  13. CVE-2018-11236

    Crítica · CVSS 9.8EPSS 6,92%Corrección disponible

    CVE-2018-11236

    stdlib/canonicalize.c in the GNU C Library (aka glibc or libc6) 2.27 and earlier, when processing very long pathname arguments to the realpath function, could encounter an integer overflow on 32-bit architectures, leading to a stack-based buffer overflow and, potentially, arbitrary code execution.

    • Actualiza a 2.27-3ubuntu1.2
    Publicación Actualización
  14. CVE-2016-10228

    Media · CVSS 5.9EPSS 4,11%Corrección disponible

    CVE-2016-10228

    The iconv program in the GNU C Library (aka glibc or libc6) 2.31 and earlier, when invoked with multiple suffixes in the destination encoding (TRANSLATE or IGNORE) along with the -c option, enters an infinite loop when processing invalid multi-byte input sequences, leading to a denial of service.

    • Actualiza a 2.27-3ubuntu1.5
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →