p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de libxslt

Vulnerabilidades publicadas para libxslt en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 8

  1. CVE-2025-11731

    Baja · CVSS 3.1EPSS 0,28%Sin corrección publicada

    Libxslt: type confusion in exsltfuncresultcompfunction of libxslt

    A flaw was found in the exsltFuncResultComp() function of libxslt, which handles EXSLT <func:result> elements during stylesheet parsing. Due to improper type handling, the function may treat an XML document node as a regular XML element node, resulting in a type confusion. This can cause unexpected memory reads and potential crashes. While difficult to exploit, the flaw could lead to application instability or denial of service.

    Publicación Actualización
  2. CVE-2025-7424

    Alta · CVSS 7.5EPSS 1,3%Corrección disponible

    Libxslt: type confusion in xmlnode.psvi between stylesheet and source nodes

    A flaw was found in the libxslt library. The same memory field, psvi, is used for both stylesheet and input data, which can lead to type confusion during XML transformations. This vulnerability allows an attacker to crash the application or corrupt memory. In some cases, it may lead to denial of service or unexpected behavior.

    • Actualiza a 1.1.34-4ubuntu0.22.04.5
    Publicación Actualización
  3. CVE-2025-24855

    Alta · CVSS 7.8EPSS 0,36%Corrección disponible

    CVE-2025-24855

    numbers.c in libxslt before 1.1.43 has a use-after-free because, in nested XPath evaluations, an XPath context node can be modified but never restored. This is related to xsltNumberFormatGetValue, xsltEvalXPathPredicate, xsltEvalXPathStringNs, and xsltComputeSortResultInternal.

    • Actualiza a 1.1.34-4ubuntu0.22.04.3
    Publicación Actualización
  4. CVE-2023-40403

    Media · CVSS 6.5EPSS 1,33%Corrección disponible

    CVE-2023-40403

    The issue was addressed with improved memory handling. This issue is fixed in macOS Ventura 13.6, tvOS 17, iOS 16.7 and iPadOS 16.7, macOS Monterey 12.7, watchOS 10, iOS 17 and iPadOS 17, macOS Sonoma 14. Processing web content may disclose sensitive information.

    • Actualiza a 1.1.34-4ubuntu0.22.04.4
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →